Issue with iOS 17 and Tidal

Using an iPhone with iOS 17 and tidal connect doesn’t connect. It shows it is on the phone but it won’t play on the 222.

OSS 117, what have you done to Tidal Connect ?

Have you tried to restart your phone and install the app again ?

Yes. Spotify connect doesn’t work either. Will do a factory reset on the 222 when I get home tonight

1 Like

This won’t help, but my phone is on 17.3.1 and Tidal Connect works fine on my Nova. Maybe all the 222 needs is to be unplugged for a while, rather than a full reset.

I’ve not tried an iPhone, but Tidal Connect works from my iPad running iOS 17.

It has been unplugged for a while. I bought it preowned as the original buyer only had it a few days. I just powered it up over the weekend.

Thanks for the input

I had the same problem a few days aago on my nd555. The usual solution is to log out of the tidal app, log out of tidal on the Naim app. Log ind on the tidal app and log in again in the Naim app. This time the solution was easier. I believe something like log out in tthe tidal app. Log in again and close the app in the app switcher. It would be easier and more correct if I new the fast way to search for my own posts on discord.
The way is not fast not for me intuitive but here is what I wrote:
Strange. When I try to play using connect nothing happens. Using airplay it works fine.
After playing using airplay forcing the tidal app to play. Going back in and selecting connect the album plays as expected.
Always a new routine for troubleshooting to follow.
One interesting observation I had to log in to my tidal app earlier but that did not solve the problem just gave access to my tidal collection and playing

I had similar issue, and Duncan with his expertise from Naim support helped me resolve it as follows.
Last step private Wi-Fi setting was the issue for me.
iOS - Settings to Check and/or Change

On your iPhone or iPad, please go to…

Settings > Privacy & Security > Location Services
Ensure that location services are turned on. Your network requires this to find devices.

Settings > Privacy & Security > Local Network
Check that the Naim App is selected (Green). If the App is already green, please tap to turn off (grey), and then re-tap to turn back on. A new command needs to be sent to the network, and restarting the setting will do this.

Settings > Wi-Fi > Select your Network
Head to your available Networks and tap on the network you are using, it will have a tick beside it. Look down the displayed settings, for the “Private Wi-Fi Address” toggle button, and disable it.

After making any changes to the settings of your home network and/or router, it is advisable to restart your network and network connected devices.
This includes The main Router, The Naim App, and your Naim Unit.
Hope this helps! Good luck.

1 Like

Thanks for the input and ideas. It connected after the factory reset and the Spotify Connect and Tidal connect work fine now.

Be interesting to see when or if Naim adds the Tidal HiFi.

1 Like