Loosing albums on U serve

And in addition to what Chris says, if albums are stored on a NAS then it’s important to check that the NAS still has SMB1 active. Mostly this gets shut down by default by operating systems these days but the US can only work with SMB1.



I am having the same problem with my Unitiserve connected to a NAS (Synology DS215j). I thought it happened after I updated the Naim app to the latest version although that could be a coincidence. The firmware on the Serve is also the current version and I have updated the software on the NAS too. At David’s suggestion (thanks) I have checked that SMB1 is enabled and it is. The only thing I can see on the Naim app is the server icon - when I open it there are no CDs. No recent rips and no old ones either. Sorry not to offer solutions but you are not the only one Rsfitzg! I am an antipodean too so maybe that is the issue…

I experienced this once (randomly). After uninstalling and re-installing the Naim app, all the files re-appeared.

Has no-one mentioned that you guys have to hold your phones upside down, otherwise all the music files fall onto the floor?

I experience this on a regular basis, sometimes even halfway through a listening session. I don’t know what causes it, but I control the Serve via an iPhone. A hard restart of the iPhone restores all of the music to the All Music view on the Serve. It’s a bit annoying though.
One thing I’ve noticed is that if I use another AP like Roon, to control the Serve, then I don’t experience this issue at all, and the music is always available…
Unfortunately, the Serve sounds significantly better on its own, rather than through Roon, so I tend to put up with the occasional irritations.

Thanks - tried restarting the phone, reinstalling the app and rebooting the NAS. No dice. Might have to get a networking nerd in.

Dang! Sorry to hear that :frowning:

If it’s in your downloads folder, you could try moving (or copying) a couple of the annum folders to a new location. This would force the UnitiServe to index the moved albums (etch it would consider as new).

This is a trick I’ve used in the past with my UnitiServe and now Core when I want to make a change to an album but but have to reindex the entire database.

If this doesn’t work, check that the permissions on the download folder on your NAS are right. It might pay to reapply the permissions across the folder just to be sure

JonoB you may be the networking nerd I’m looking for! Found “Indexing Services” and clicked that. The computer and the NAS were satisfyingly busy for a few minutes before announcing everything was re-indexed. But again - SNAFU - server could be seen but no music files.

Sorry - a I might have led you slightly astray - the sentence should have been “want to make a change to an album but don’t want to reindex the entire database”

The key thing here is that if you change the name (just adding a number after the folder name or an extra space in between the words of the album will be sufficient) of the album folder in the downloads share (using your PC or Mac), it should be re-discovered by the UnitiServe.

If you need a hand with how to do this, let me know and I’ll post a PC or Mac set of steps.

And yes, I was a networking nerd in a previous life - it’s something (a stain?) that never leaves you :wink:

I’d love a set of Mac steps - thanks! Networking nerds are surely like drummers and goalkeepers? Never short of a gig?

You’ll need to know the IP address of your UnitiServe. You can get this from the desktop app if you don’t kow it.

  1. Open up finder, and connect to a server (command-k)
  2. Access your UnitiServe via this command : smb://xxx.xxx.xxx.xxx
  3. (where xxx is replaced with your IP address eg 192.168.1…53)
  4. You’ll be able to browse through the drive on your UnitiServe and find the downloads folder from this finder window.

As I mentioned in an earlier post, just renaming the folder name of one of the missing albums should be sufficient for the UnitiServe to catalogue that album, and hopefully it’ll be visible in your streamer.

Thanks so much for that JonoB. You set it out very clearly. Sadly while there was a lot of activity on the NAS and something was clearly going on I still can’t see the files from either the naim app or n serve. Ah!

Hmmmm. That’s frustrating. Can you see the missing albums on the UnitiServe even you contact through the desktop app?

Are the missing albums on the NAS in a store, or a share? (I had both on my Synology NAS with my UnitiServe - the store for albums that the US ripped, and a share for the albums I had purchased digitally)

The other thing you might want to try is removing the store (or share) from the configuration of your UnitiServe, and then re-adding it.

If it’s a store on your NAS, the method that I found worked was to add the NAS volume as a share first (using the app or n-serve), and let the UnitiServe index all the music, then convert it to a store (also in the app)

Super frustrating! But the U Serve has been good to me for a long time. Not ready to give up on it yet…

I’ve never used the desktop app before but have given it a go and that has come to nothing too. On a Mac the browser tab says “Naim Hard Disk Player” but the webpage itself is blank. A Windows machine goes one better. The page is not blank but just says “This plug in isn’t supported”. A victory for Microsoft?

I think the missing albums are in a share. I only ripped CDs - I haven’t really explored hi-res files. The rips went straight into a “medium res” folder and that folder’s contents aren’t visible.

Assuming that this folder is a share whereabouts on n-serve can I remove it and then add it? On n serve all I can see is the name of the serve, the ip address of the U Serve and “Naim HD Player”. I don’t see how I can remove and add an individual folder like my medium res one.

I used to struggle with the puck on my CD player so perhaps streaming was ambitious…

This will be because Adobe have abandoned Flash, so it no longer works. See here for an alternative way to access the so-called browser interface:

Of course there is also N-Serve for Mac, but when setting up network shares, music stores etc. the browser interface is your best bet.

1 Like

Thank you very much ChrisSU - a handy tip! Unfortunately I get the same result with a blank page. I’m beginning to think that situating the U Serve near the teenager’s PlayStation may have been a bad idea and that a yanked power cord out of the U Serve one too many times might have upset it. Off to the dealer I think…

In Unitiserve jargon, there’s a ‘network share’ which you would only use to store music other than CDs it has ripped itself. These go into a ‘music store’ where you see them in the MQ folder.
If you are using a music store on a NAS rather than the US internal hard drive (if it has one) you or your dealer will have set this up at some time in the past.
One way or another you really need to connect to the US via one of the Naim user interfaces to see what is going on. Are you saying that none of these work - including N-Serve for Mac, N-Serve for iOS, the browser interface, and the Windows DTC? If so then it may be that the drive itself has a problem.

What happens if you log into the Synology NAS? You should be able to browse the music folders there, then you will at least know whether or not they are intact. If they are corrupted you may need to restore from backup or replace the drive. If everything is in order that points to an issue with the US.

Solved! In the end it was just a matter of going into the N Serve desktop app and disconnecting and reconnecting the Network Serve and Network Stores as JonoB and ChrisSU and others have suggested. It was my lack of ability around using N Serve that was holding me back but Jonathan at Real Music in Wellington came to the rescue. They are superb dealers (not of Naim any longer sadly) - supportive and friendly. Thanks to all the posters - I hope the OP solves their problem shortly.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.