Loosing albums on U serve

Has anyone had experience of loosing albums on their u serve. I can see that they are still on my qnap nas but not on the app. I have tried a rebuild of database but no joy. Any suggestions. We are a bit short on good tech assistance these days down here in the antipodes.

Do you mean in the backup to the nas or the musik store on the nas?
I have seen individual tracks that was not included in the album but the files were in the backup and on the harddisk on my ns01. Hard to explain how or why this happens.
One solution is to copy the files from th store to the music downloads folder or a folder on the nas that is indexed by the userve.
Claus

I’d try rebooting everything, one by one and see if the missing albums reappear.
Also remember that depending on how many albums you have, it can take a long time to rebuild the database, in my case a couple of days. (1200 ish albums)

Are you looking at ‘All music’ or ‘CD collection’?

If you have albums loaded in the downloads section, these won’t show up if you’re looking at CD collection.

All my downloads have dissapeared from app. But also random albums are no longer visible on app hence not playable. They are all ripped cds.

First, is your firmware up to date? You should be on version 1.7c.
Second, when did you last rip any CDs, and is it generally more recent rips that are disappearing? You might think that once the rip is completed it would remain visible, but in practice I’ve found that this occasionally does not happen. It tends to be worse if you save to FLAC rather than WAV as the transcoding process takes time.
Finally, I would suspect a network discovery issue might be causing problems. If you are storing your library on a separate NAS there are 3 way comms going on between NAS, Unitiserve and N-Serve app so any interruption or delay might cause issues.

And in addition to what Chris says, if albums are stored on a NAS then it’s important to check that the NAS still has SMB1 active. Mostly this gets shut down by default by operating systems these days but the US can only work with SMB1.

Best

David

I am having the same problem with my Unitiserve connected to a NAS (Synology DS215j). I thought it happened after I updated the Naim app to the latest version although that could be a coincidence. The firmware on the Serve is also the current version and I have updated the software on the NAS too. At David’s suggestion (thanks) I have checked that SMB1 is enabled and it is. The only thing I can see on the Naim app is the server icon - when I open it there are no CDs. No recent rips and no old ones either. Sorry not to offer solutions but you are not the only one Rsfitzg! I am an antipodean too so maybe that is the issue…

I experienced this once (randomly). After uninstalling and re-installing the Naim app, all the files re-appeared.

Has no-one mentioned that you guys have to hold your phones upside down, otherwise all the music files fall onto the floor?

I experience this on a regular basis, sometimes even halfway through a listening session. I don’t know what causes it, but I control the Serve via an iPhone. A hard restart of the iPhone restores all of the music to the All Music view on the Serve. It’s a bit annoying though.
One thing I’ve noticed is that if I use another AP like Roon, to control the Serve, then I don’t experience this issue at all, and the music is always available…
Unfortunately, the Serve sounds significantly better on its own, rather than through Roon, so I tend to put up with the occasional irritations.

Thanks - tried restarting the phone, reinstalling the app and rebooting the NAS. No dice. Might have to get a networking nerd in.

Dang! Sorry to hear that :frowning:

If it’s in your downloads folder, you could try moving (or copying) a couple of the annum folders to a new location. This would force the UnitiServe to index the moved albums (etch it would consider as new).

This is a trick I’ve used in the past with my UnitiServe and now Core when I want to make a change to an album but but have to reindex the entire database.

If this doesn’t work, check that the permissions on the download folder on your NAS are right. It might pay to reapply the permissions across the folder just to be sure

JonoB you may be the networking nerd I’m looking for! Found “Indexing Services” and clicked that. The computer and the NAS were satisfyingly busy for a few minutes before announcing everything was re-indexed. But again - SNAFU - server could be seen but no music files.

Sorry - a I might have led you slightly astray - the sentence should have been “want to make a change to an album but don’t want to reindex the entire database”

The key thing here is that if you change the name (just adding a number after the folder name or an extra space in between the words of the album will be sufficient) of the album folder in the downloads share (using your PC or Mac), it should be re-discovered by the UnitiServe.

If you need a hand with how to do this, let me know and I’ll post a PC or Mac set of steps.

And yes, I was a networking nerd in a previous life - it’s something (a stain?) that never leaves you :wink:

I’d love a set of Mac steps - thanks! Networking nerds are surely like drummers and goalkeepers? Never short of a gig?

You’ll need to know the IP address of your UnitiServe. You can get this from the desktop app if you don’t kow it.

  1. Open up finder, and connect to a server (command-k)
  2. Access your UnitiServe via this command : smb://xxx.xxx.xxx.xxx
  3. (where xxx is replaced with your IP address eg 192.168.1…53)
  4. You’ll be able to browse through the drive on your UnitiServe and find the downloads folder from this finder window.

As I mentioned in an earlier post, just renaming the folder name of one of the missing albums should be sufficient for the UnitiServe to catalogue that album, and hopefully it’ll be visible in your streamer.

Thanks so much for that JonoB. You set it out very clearly. Sadly while there was a lot of activity on the NAS and something was clearly going on I still can’t see the files from either the naim app or n serve. Ah!

Hmmmm. That’s frustrating. Can you see the missing albums on the UnitiServe even you contact through the desktop app?

Are the missing albums on the NAS in a store, or a share? (I had both on my Synology NAS with my UnitiServe - the store for albums that the US ripped, and a share for the albums I had purchased digitally)

The other thing you might want to try is removing the store (or share) from the configuration of your UnitiServe, and then re-adding it.

If it’s a store on your NAS, the method that I found worked was to add the NAS volume as a share first (using the app or n-serve), and let the UnitiServe index all the music, then convert it to a store (also in the app)