Mu-So 1 gen won't connect, QB gen 2 works fine

I’v tried everything what comes to my mind.
2 gen Mu-So qb works fine with both 2.4 and 5 g wifi and that devise has bit weaker wi-fi

-I do have 2.4g network in my tablet and gen2 muso qb wich is already connected to app. I also tried 5g with no success. I also tried to connect old Mu-So first…
-Mobile data is off
-I can see on tablets wifi settings "Mu-so xxx setup “no internet connection”
-Old muso 1 gen wont work. When I’m trying setup:
*Purple light blinks
*I can see device name on the app
*I’m able to as far as "wifi setup / transferring settings - until app tells to "could not connect to product / check router an android device network settings.
I’m able to connect any other device to 2.4g network but not the 1 gen Mu-So…

I tested that mu-so works when connected with cable
Wlan is strong - tried also next to router
Password checked - device gives similar note if your password is wrong, tried that also…
Reboots with mu-so / even couple factory resets…
Reboots with adroid tablet
Deleting naim app from android device and start again.
Even airplay doesen’t connect…

Cable is not an option for me, so any ideas… I’v started too many times and a bit tired right now…

Hi, the 1st gen Musos have very dated WiFi modules which can cause problems for many. So it could be that without a wired connection, it will always struggle. This will also depend on the quality of your network hardware, and the environment in which it works.
One thing you didn’t mention doing is restarting your router. This would be the first thing I would try. Best to leave it switched off for maybe half an hour, and also turn off the Musos and your phone. Then turn on the router, then everything else.
If you really can’t run an Ethernet cable, I would suggest that you look at some wireless hardware that will give you a more robust connection. When I had a Superuniti, which used the same dated WiFi hardware as your Muso, I wired it to an Airport Express, which was able to maintain a reliable wireless connection back to the router. The Apple Airport stuff is a bit dated compared to what is available today, so now I would probably be looking at a Mesh type WiFi solution.

Thanks -1 gen used to work earlier with iPhone + Naim app. I deleted Naim app from iPhone, so that shouldn’t mess…

Also restarted wifi couple times… but just briefly - I’ll try longer period too with all of these.
I have 2 different lines comig to our flat, routers (Cisco and Zyxel) - atleast connection to routers are very reliable. (lightcable to building and inside we have CAT6)

Thank you for your help - I’ll try again :slight_smile:

So you have two separate internet connections? Presumably you also have two separate networks? Are you sure the Musos and phone are all on the same network?

Yes I do have 2 separete connection - tried both… deleted other connections when trying, even I deleted mobile connection during tests.
Tablet and Mu-So’s are in same 2.4g network.

*last option is “add manually by IP address” where do I find right one? From the app I’ll find only new Mu-So’s IP… I’ll try google first.

I tried ip-adresses:
-One wich I found from the gen 1 manual - page doesen’t exist anymore
-On from app I found Gen 2 information - I could not find how to add other device…

More with IP’2

I found 1 gen Mu-So’s ip from tablets network settings - it says “no internet connection” but youll find MAC/IP etc. I tried that ip and got message:

I also tried to reboot once again and unplugged gen 2…

So, I think this is something with Naim software related. My network is propably not guilty. Now I have to get this notice to Naim’s support. Unless someone has better ideas.

I found with my 1st gen Muso, the unit would struggle with my original wifi ssid password whereas all other devices were quite happy. Once I changed the required password on the router the Muso would happily connect again.

Thanks - I’ll try that - my password was changed when wi-fi were installed. Lets try it again.

Well, done that too. Thanks for your support. I may miss something and you probably going to point that again, but.

When ever you are connecting these beasts wireless:
-wait until purple light is flashing - there is too much hassle with a app and different light colours- if you wont get flashing purple every other move useless - just wait… or push the pinhole for a second and wait.

I think that if you want wireless systems look elswhere. Maybe gen 2 systems propably works fine but gen 1 + gen 2 seems to be “bit” hard to connect to multiroom.

My set:
-2 different internet connections (lightcable + cat6)
-2 different wi-fi routers / diffrerent connections and routers (Cisco + Zyxel)
-2 different android devices (Lenovo xx and Nokia Sirocco)
-closed all other connections, even backup mobile 4g
-closed 5g network and used only 2.4g
-closed all IOT and other devises in my networks
-tried to connect very close and couple meters away
-gen 2 works fine even without direct sight
-gen 1 doesen’t find router ,even next to router
-Tablet and cell claims to have excellent wi-fi next Mu-So’s
-even old Mu-So turns white on, but it’s still lost
-several soft and hard reboots, with different patterns
-deleted and reloaded app several times
-rebooted cell and tablet several times
-hard rebooted devises too atleast couple times
With cable both works fine and app finds them, but multiroom…

My advice, before better one’s from support: Get a cable to endpoint

Propably I miss something easy or doing something wrong, but my imagination is over and energy used… Support’s guessing is frustrating - ofcourse they may have red line, but I can’t see it yet. Answer once a day is quite slow for me. Still, thanks for the support, you are doing your best.

One other thing that might be effective is to switch the wifi mode from a mixed 802.11 b/g/n to just 802.11n on the wifi routers.

I have dual band routers and have separated 802.11n only to the 2.4GHz frequency and 802.11ac only to the 5GHz.

Thanks - you are right - routers (both) tech data says: 802.11 b/g/n 2.4 GHz.
If that is the solution I have to buy one router for these… Or I may destroy almost perfectly working interface at my home and I’m nor sure if I can choose “n”…

Is the solution really that simple - router shuffles 802.11 protocol (?) - so it may have requisite “n” connection randomly… That would explain random work/not working when trying to setup…

Not knowing which routers you have other than the brand, I can’t advise whether it is possible to specify which protocols of 802.11 can or cannot be assigned for transmission. However, in general, it is possible to specify the protocol used on the SSID from the configuration webpage of the router.

I’m not sure I follow your suggestion of buying ‘one router for these’ or router ‘shuffle’.

Me neighter - just guessing how router works, really don’t know.

I think i’m going to get Cisco Small Business RV110W router for these. Those are more reliable than zyxel and I’v been told that they have more settings to choose.

Private message me. I might be able to help with your existing WiFi gear rather than you going to the expense of buying a new router when there may be no need.

Hi, Thanks - I’v been searching PM button… and finally found this:

Stronger wifi is Zyxel AC2200 MU-MIMO Dual-Band Wireless Gigabit Router

This one if for “entertainment” and backin up other one (Cisco RV110W wich is used to working.

Are you aware of whether it is setup in Router mode or AP mode? And if in AP mode what address it has for logging in to its Web Configurator pages. No need to tell me the address but just that you know it.

Actually not - I believe that Zyxel was outdated and I bought another Cisco RV110W - it’s more reliable and has more settings. Probably that was not the right choice…

What I have rigth now - I’m not sure how I got here:

  • It looks like I cant get multiroom without spotify premium (ok spotify’s sound…) I’v used free Tidal already and haven’t checked that yet.
    -With internet radio multiroom works fine - just tiny delay
    -can’t get updates to older muso - app says “update available” but can’t find right path…

I’v been thinking what went wrong in the first place.
-If you can’t get connection with you tablet or phone try another. When you have connection to another you’ll probably get another working too, like magic.
-I don’t believe than new router had anything to do with result.

I believe that problem is in app - why Android phone (Nokia 8 Sirocco) got connection easier / earlier but not Lenovo’s Android tablet… Even when you see Mu-So’s in your wifi list.
I think, that gen 2 devices work’s fine, but these 1 gen Mu-So’s may be difficult to get wireless…

Thank you for your help!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.