Mu-so 2 HDMI ARC nconsistent

I have a Mu-so 2 connected to a Sony android TV with HDMI ARC. The function is some what random. Sometimes it works flawlessly, and the day after it doesn’t work at all. It always powers up with the TV, but then the TV prompts “TV speakers active” and “Sound system active” back and forth until ultimately stopping and TV speakers.

Sometimes everything works and it even turns off when turning the TV off. Sometimes everything except turning off with TV works.

I’ve tried all the power cycling tips, changing HDMI cable three times (high speed cables), tried different ports (though I know I should use ARC, but it was worth a try), even tried different power outlets. Still the same behavior. Frustrating.

I have also tried all sorts of settings in the TV. Sony’s CEC function, Bravia sync is enabled. Sounds system is prioritized. Output is set to PCM.

I know one option is optical cable, but I really want the convenience of HDMI.

Please tell me there’s a solution for this. It’s been bothering me for a year now. I really like the Mu-so (music streaming works great) but this is ruining the experience.

Is the firmware in both the Mu-So2 and the Tv up to date?

It seems it’s a constant moving target with many TVs getting the handshaking just right. I know Naim work hard to try to ensure as wide a compatibility as possible but every brand and even sometimes the model is slightly different. Have you been in touch with Naim support on this?

Yes, they’re both up to date. Updated the Mu-so to 4.3 today but it’s the same.

Haven’t been in contact with the support. I guess I should. HDMI seems like a jungle.

It can be, yes. I would suggest getting in touch with Naim support to see if there’s anything that can do.

I’ve sent the support an email.

But hopefully someone here have had (and solved) the same issue.

I had a nightmare of a scenario using the HDMI ARC input on my Muso 2. In fact I had to send it to Naim twice to fix and both times they told me they couldn’t replicate the problem and intimated I was the problem. This took 6 or more months along with shipping costs and the loss of my primary home audio. In the end, someone from Focal/Naim in a follow up email suggested electronic interference from the tv. That was it. I moved the name to a diff position from the tv and used the optical. I know it’s not as convenient but problem solved. My tech expertise is rather limited but perhaps there are solutions while still using that input, but I opted optical for one less headache and potential permanent damage. Good luck.


Doesn’t sound fun at all. Optical feels like the last resort. I talked to Naim support, and they told me a fix is on it’s way (no ETA though). In the meantime I disabled hdmi auto-switching and just let the TV fully boot and then turn on the muso manually. Have been working so far.

Huh, so kept the HDMI ARC? Seems then that our problem might not be from the same flaw if they’re suggesting interference of some kind. Perhaps I’m missing something about the nature of that connection. How long now has it been since you’ve switched the switch? BTW Thank You for sharing…


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.