Mu-So 2 not powering up [Solved]

My shiny new Mu-So 2 Wood Edition turned up yesterday, but when I plug it in to the mains the LED indicator flashes red once, then nothing. I have pressed the reset button for >10 seconds, but still nothing.

Google & Naim support webpage have lots about when the LED flashes (repeatedly) red, but nothing about a single flash then nothing.

Has anyone else had this?


Does anything else light up? Top volume control, bottom panel light? Is the power connector shoved in to the socket fully?

No, nothing lights up at all; I have tried two power leads in to a known working socket. The only activity is a brief single red flash when the power is connected.

Hate to say this, but sounds DOA… my Mum had exactly this symptom and unit had to be replaced…

Oh no! :fearful:

I will email Technical Support and see what they say…

You need to get in touch with the dealer and ask for a replacement.


As @HungryHalibut says, contact your dealer in the first instance. I know how disappointing this is, but your dealer should be able to sort this out quite quickly, as should any authorised retailer such as John Lewis etc…

1 Like

I sent an email to the vendor (Basically Sound in Norwich), and they replied within two hours - on a Sunday! They suggested that I should try it using ethernet, and when I did so the Mu-so ran a self update and worked.

Removing the ethernet cable and setting it up again via wi-fi worked, so I am a very happy chappy!

Hat Tip to Basically Sound too - fabulous service.


Excellent news! You’ll love it too!

1 Like

Wow, great result! :+1:t2:

1 Like

That’s great, and what super service. No need to exchange it after all. Result!

1 Like

I tutor high school students in reading and writing for the SAT examination in the U.S. One thing we look at is misplaced modifiers. That sentence would not pass muster. I know, because if it were accurate, you couldn’t be writing about it.



Was going to suggest using ethernet. My power button has not been working for ages (out of warranty).
If you used ethernet, the power button isn’t necessary. But - May just do a reset to see if its function gets restored.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.