Mu-So Gen 2 - connection & setup issues

I’ve seen some posts related to Mu-so Gen 2 connection & setup issues. Tried several things based on the suggestions, but have not been successful.

As you can see in the screenshot setup is ending in a error when using the following:

Phone: iPhone 12 Pro Max
iOS: 14.3
Two WiFi networks (2.4 & 5 / Mesh) with different names. Errors happens with both.
Led: blinking purple

Setup works with iPhone Xs and Xs Max with iOS 14.3.

Once setup has been completed with any of the two iPhone Xs I can also stream from the iPhone 12 Pro Max on Spotify, however can’t use the Naim App.

Thoughts? Appreciate any help.


This is almost certainly a router or network setup issue.

When you say you have two Wi-Fi networks with different names are these provided by the same device or separate devices? If two devices you may have created a subnet or are operating two routers in router mode, so are suffering from double NAT, which will give the error you see.

The odd thing is that I can ‘access’ the Mu So with two devices iPhone Xs, and not with the App on the iPhone 12.

My wife has a iPhone 12 and the Naim App finds and operates my Qb and Atom without any issue. Delete the App and re-install to see if this helps. Maybe you failed to acknowledge the pop up request to allow network access.

1 Like

Depending on how your network is configured, if you have the 2.4 and 5GHz networks on separate SSIDs I can see that this might cause issues when the iPhone is on a different network to the Muso.

Reinstalling the Naim App did the trick. Thought I did it already a few days ago, today it worked. Thanks!!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.