Multiroom not working for externally connected devices


I have a number of Naim Uniti players, which I use to Multiroom. This functionality works as it should for any internal device, e.g., Naim Uniti Core, Internet Radio, DAB+ Radio. However, any device that is connected directly to either my Atom or Nova, such as a CD player (Naim CD5si), or Project Turntable will not work. On the Atom or Nova I can see that a multiroom connection has been made but there is no sound.

I have tried this functionality at my local Naim dealer and externally connected devices work correctly. I have logged this problem with Naim but I am yet to receive any ideas as to how I may resolve this problem. I should add that all the Naim players are connected via CAT6 Ethernet all connected to the same switch.

Does anyone have any ideas as to what may be causing the problem?


1 Like

I very rarely use anything other than my Core, Qobuz and the internet radio but I just played a cd (Audiolab CDT6000 to my NDX2) and multi room worked fine.

Hopefully someone might have an idea about what’s going on.

Thanks Pete - will keep my fingers crossed that someone does!

@Richard.Dane he my be able to point you in the right direction. Cheers.

I’m no networking expert here so not sure what the issue might be. One for Naim support I reckon.

@njvm I have a Nova which currently has a Quad FM4 tuner connected to the analogue inputs on the Nova. No issue with m-room - of which I am a regular user.
First of, you have made no mention of what firmware each of your streamers is running. Best to avoid the word “latest” and detail each one, which you can obtain by looking at your control point. I won’t remind @Pete_the_painter about firmware numbers - he’ll remember getting them upside down, but then from where the rest of us are…!

Also worth posting, or at least detailing for support, the control point you are using and again the model, OS version and app version details.

@Richard.Dane has already pointed you towards support. A response is by all accounts unlikely to be prompt, due to a high level of enquiries.

In the interim, since it works at your dealers IIUC, then without knowing your router, which would be helpful, you might try the following.

First decide which Uniti unit is to be master and then choose a slave. Then switch off every streamer, restart your router and wait 30 mins, before only connecting first the master, then 5 mins later, the slave. See if that works, if not, switch units around, remembering to leave switched off any other units and restart the router again.
You make no mention as to whether this is the first time your have tried what you have reported or if it worked in the past?
Final question, do you have anything else connected to your network - any IoT items, lights, sat tv boxes - anything at all? If so, disconnect all these items before trying the test suggested. It is likely your router is blocking the m-room interaction, but w/o knowing the model, can’t be more specific.

ʇnoqɐ ƃuᴉʞlɐʇ ǝɹ’noʎ ʇɐɥʍ ʍouʞ ʇ’uop


ʇnoqɐ ƃuᴉʞlɐʇ ǝɹ’noʎ ʇɐɥʍ ʍouʞ ʇ’uop

…you folks down under certainly spell funny.

Do you sit right side up when you read the forum?


No but being upside down seems a bit of a (funny) cliche that we’re use to down here. I just thought I’d respond in kind. :grin:

1 Like

What’s wrong with his spelling?
As long as @Pete_the_painter only reads upside - I’d be concerned if he had a drink that way!
I sure as heck hope he doesn’t drive his new VW that way either - likely he may not get very far.


@sound-hound - thanks for your comments - they were very useful. I did what you suggested and eventually narrowed it down to the wiring from the Switch (Netgear GS316EP) to the Nova. Further testing revealed that it was actually in the expensive hand made ethernet cable that I had made up for me in Canada, which connected the Nova to the wall plate. Replacing this, with a standard Cat6 cable resolved the problem and I am now able to multiroom from both the Nova and Atom when external inputs are used.

I suppose what I don’t understand is why the Atom would not multiroom with externally connected inputs (Kenwood DP-5010) when the Atom was correctly connected to the Switch and why multiroom would work on all devices if the source was the Core, DAB+, Internet radio or Qobuz?

Thanks again for your help.


1 Like

Pleased you have achieved a result. Restarting devices often solves problems, without being apparent why. I guess m-room is now more widely used as ever more Muso units are used in addition to Uniti / classic streamers. M-room was not on all streamer units. M-room initially at least, was not available on NDS and it caused some debate at hq - my comments had been fed back, amongst others, that I had declined to upgrade from NDX for that reason.

Enjoy the music!

edit - IIRC cat 5 patch cables are more than adequate - i’m not sure how cat 6 is considered sonically.

I used Cat 6 network cables as my house is cabled using this standard.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.