Muso 1st gen red led flashing

Muso has suddenly gone off and red led now flashing. I can reboot system and it works for about 5 mins then goes off and red led flashes. I’ve got the latest firmware installed. Can anyone offer any help or is it a return to manufacturer for repair ?



Normally , red is bad. (Sh*t … it rhymes… so it must be true)

I would contact the dealer. :grimacing:

Boingboing - Don’t panic yet.

Red and bad don’t really rhyme so you might be OK.

1 Like

From the mu-so manual:


Many regards,

1 Like

Panic already set in lol I think it’s got to go in for repair

One last try press and hold the reset butting for 5 mins …
it works some of the time when you see red

I thought that the 1st Gen muso were not repairable?

5 mins !!! Are you sure

Naim introduced a muso 1 repair scheme a few months ago.



The 5 min reset has brought a few back to life.
Worth a try.
Normally when it’s a catastrophic failure you can smell it.

That’s good to know. I have an original muso. No problems to date.

Ok ready to give it a go

Tried holding the pinhole button in for 5 mins but again it worked for a few mins then the dreaded red flashing led again :rage:

Worth a try …that sucks but worth a try.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.