Muso 2 Firmware not updating to v4.2, preventing set up of unit

I just got a Muso 2, which arrived with firmware v4.1.1.
Setup stalls every time when it tries to update to v4.2.
I have tried at least 8 times.
It goes through the full update cycle of about 10+ minutes every time, and it seems to complete the install, but it never actually happens.
I tried the usual low-tech solutions methods of shutting it off, unplugging, and rebooting.
But v4.1.1 keeps showing every time.
Unfortunately, it will not let me use the old firmware, keeps asking for a new update, and does not allow me to use the machine.
I am psyched to use this beautiful device, but seem to be caught in an endless loop.
Any suggestions?

Hold tight once the guys in the UK wake up I’m sure they’ll be able to help.

Have you tried a full reset, by using the pinhole at the side. This will take it back to factory settings.
Are you connecting via wifi or ethernet cable?

1 Like

I tried a reset with the pinhole, but got the same result.
And I am connecting through WiFi.

Try connecting via Ethernet even if just temporarily to get the update completed.


Doing the firmware update through an Ethernet wire instead of WiFi seems to have done the trick!
Everything is working well now.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.