Muso 2 QB setup

Hopefully I’m in the right place to get some guidance on this.

Attempting to set up a new Muso2 Qb. After an indeterminable time of Orange status I eventually got the flashing purple and was able to set up the WIFI connectivity. The Qb shows on the windows network.

However…it’s a no-show in the app which has been “Network scan in progress” for about 40 minutes and I’m guessing is unlikely to resolve. Any suggestions?


OK maybe I spoke too soon. Qb has disappeared from the Windows Network. It’s status light is still showing white, which Possibly means it thinks it’s connected to wifi?


OK, so tried a resent. Qb has gone from status Orange → Purple → flashing Purple → White (with requested inputs from myself). Once more it is showing in the windows network.

The app went into a Waiting for network and now, after a few minutes, has

Anyone any thoughts on how to resolve this?


Sounds faulty. My Muso2 has been back twice for a new wifi module thingy.
Even when it works, it often disappears from the app, requiring a hard restart.
When it works it is great, but I’ll not be buying another.
My ndx2 that is in the same room and further from my router never drops the WiFi.

Id suggest yours is faulty so return it.

1 Like

Just to check but do you have any WiFi extenders etc?

The BT hub is wired into an Ethernet backbone. There are an additional four access points connected (all hardwired) to that (old house thick walls). They’re all set to the same SSID and password, works seamlessly.
What appears to be happening is that when my phone is on the same access point as the QB the app can’t find the QB. If I move to a different part of the house and the phone transitions to a different access point then the app connects to the QB. If I then move back to the kitchen then the QB gets lost.


It’s possibly a setup issue with the 'access points, it may be worth checking this.
It’s not the the App can’t find the QB but that the Qb’s discovery announcement is being blocked.

Well try a reset on the access point and see if that helps.


Looks like the Access Point is on it’s way to that great network in the sky. Have hardwired the Qb (the sockets and cables were in place as part of the kitchen build, I just needed to patch them in in the attic) and it’s been behaving itself for a few days now. Replacement Access Point ordered.


I used to have a Muso Qb, but sold it on.

Continually had to keep re-setting it to get it and the app talking to each other. Was a complete PITA and just got fed up with it.

Nice concept though, but just didn’t work for me.

Ended up getting an Internet Radio Adapter that worked well, before eventually ending up with the current Linn Klimax DS/3 Katalyst streamer.


Interesting how experiences vary. I got my QB1 several years ago at a good price. I’ve always used it wirelessly and it’s never given any problems, in spite of the supposedly rubbish wifi of the first version and being some distance from the router with two brick walls in between. I can even stream Qobuz to it using my Atom and multiroom.


1 Like

Same here. So has a QB1 it’s been brilliant and flawless from the off.

When it worked it was fine. But after it went on stand-by or switched off and then when switched back on, would have to be re-linked to the app again.

The person who bought never had any issues with it at all.

As you said, strange how things work out.


Same with my Qb1 on WiFi. It’s always there in the app even if it’s weeks since I played anything on it.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.