Muso (2nd gen) constantly drops network connection

Raised before, but thought it may have been addressed by now. No other device connected to the network drops the connection as much as the Muso. My NDX, fine. Apple products, fine. B&O, fine. Massively frustrating. No, it’s not my router. No, it’s not the quality of the network. It is this product specifically that has some type of fault.

1 Like

Link to Naim support contact details

Do you really mean drop a network connection, or disappear from UPnP and the Naim app.
The former would be rare and suggest a hardware failure or bad Ethernet lead. It’s also quite hard to determine without using the right equipment… but the switch link light being extinguished would be an indicator of an actual dropped network connection
The latter will be software related and possibly interoperating with other devices on your network. The network underneath would be fine… so nothing being dropped, it’s just the software might be struggling. This sort of thing has been discussed many times on the forum… but if having read those numerous posts including topics like enabling or disabling IGMP snooping on your wifi router or switches then best contact Naim support. Wifi can also be issue when you have many old kegacy devices sharing your WLAN… for them all to work the WiFi network has to downgrade in performance.

Is it connected by ethernet?

Thanks Simon.

1 Like

I have my Muso 1 connected by cable to the router.
Otherwise it would be always dropping etc very annoying.
This would happen even if i disconnected TV, Laptops etc.

If only the software was as good as the sound, unfortunately it isn’t …

1 Like

It’s not software, it’s the poor WiFi performance of the older legacy Naim units. They are all like that. It’s a hardware limitation.

The newer ones aren’t much better IME. They simply added WiFi 5 support, but to me the implementation doesn’t seem noticeably better beyond that.

1 Like

I’ve experienced same problem on my MuSo (Gen1) since the general issues with Vtune around Christmas. My MuSo is connected via Ethernet cable to the router. Radio sound stops and MuSo disappears from the Naim App. A few minutes later it re-appears and radio sound resumes. It doesn’t appear to be a Wi-Fi issue. I haven’t had the same issues with other Naim gear on the system.

1 Like

Have you tried unplugging it from the mains, leaving it for a minute and then plugging it in again?

I have tried this previously and sometimes it works, sometimes it doesn’t. I think the most recent issues have been to do with the Vtuner problems. I see from another thread that Vtuner has been playing up again over the past few days.

I have a muso 1. It drops out 1-4 times a month. Need to reboot Ethernet did not make a diff. not kidding. It’s a pain but I have accepted it as the cost of doing business

2 Likes

Oh dear yes… this moves into the vagaries of group membership functions in consumer software and network equipment… though to be fair has got better more recently in many products.
Are you using Android or iOS. Some Android implementations are not well behaved here… you could try another different device or try an iOS device, or enable always keep connected in the Naim app… but if no luck, try the following.

Does your wifi and router and/or switchports have an option called ‘IGMP snooping’ it could be in the advanced settings… if it does try disabling it… it really should be on, but if it’s the only way to have things work on your devices on your network you will have to sacrifice LAN efficiency and disable it.

If you still have no luck, then you may need to consider changing your wifi solution as it then would appear to have bugs/faults/deficiencies that are impacting your audio applications.