Muso vanished from iPhone app

Having had the Muso repaired in January and it having worked faultlessly since, it has rather weirdly disappeared from my iPhone Naim app. The Muso Qb I have in another room is still there and two others in the family still see the Muso in their iPhone apps.

I can also see it on the Naim app on my Pixel (awful implementation of the app compared to the iPhone, I think).

I had read that this could happen when the iPhone is on the 5GHz band on wi-fi, but I think both other iPhones are connecting to that so…?

All a bit weird. Any ideas?

The 5 GHz thing is usually a red herring, unless your router is very old.

Have you tried unplugging the muso from the mains, waiting a half a minute and then plugging it in again?

If that doesn’t work, try restarting the router too, turning the muso on after the router has fully restarted.

You could also try restarting your iPhone app, (but deleting it and reinstalling it is another red herring as restarting it usually had the same effect).

I would start by restarting your iPhone app.

Thanks. Restarting the app has no effect unfortunately. (I did also try reinstalling and the Qb appears, the Musi doesn’t).

Router is a regular Smart Hub 2.

Will give the “have you switched it off and on again?” a go when I get home later.

Good luck! I will look out for your report back. Fingers crossed!

Alright, I have no idea what’s going on!

Unplugging the Muso and plugging it back in again did nothing. For a brief time it also disappeared from the app on my Pixel.

So I switched off the two BT extender discs to start off. Still no change. With those left switched off, turned off the router, the Muso and the Qb, as well as my iPhone and Pixel, and my wife’s iPhone.

Started the router up, waited for it to connect, then switched the Muso and Qb back on, then all three phones. Left the BT discs off. After a while the Qb appeared back on my iPhone app, but no Muso.

Both popped back up on the Pixel.

At this point I gave up. At least I have control using the Pixel, as slow as that interface appears to be to do anything compared to the iPhone.

Then I switched the BT discs back on. As these were restarting, and I’m pretty sure before they got a stable connection, I looked at the iPhone app and…

I have no clue! Everything does work again, although neither Muso nor Qb are currently showing in my wife’s iPhone app. :crazy_face:

Let’s see how long it lasts for.

Get a better Router. I’d recommend an Asus RT-AX88u you also might find you won’t need extenders

Sounds very similar to the issues I’ve had for coming up 4 years. I have found something that seems to work.

I have a Qb2 (wifi) and Muso 2 (wired) and have BT smarthub2.

The Qb2 would constantly disappear off the naim app and airplay. Would show sometimes on my iPad but not iPhone or vice verca etc.

I have noticed that whenever the Qb2 was connected to 2.4Ghz band, there would be no problem. In fact the router designates it as not being dual band compatible (which it clearly is) which maybe where the issue emanates from?

Anyway, I tried switching 5Ghz band off and things were fine, but other streaming devices on my network did not like it, so resumed both bands and returned to the same problems.

I have now found that if I switch off the “smart” part of the 5Ghz band on the router and fix the channel (currently 36) everything seems to work, the Qb2 remains visible on all apps and airplay is rock solid. This will work for a number of weeks it seems and then I have the issues again. If I look at the router,I’ll see that the Qb2 has migrated to the 5Ghz band. I then switch the smart bit on the 5Ghz band back on and sometimes that will be good enough to fix it for another few weeks or sometimes I need to switch the 5Ghz smart mode back off.

But doing this has certainly made things a lot better i’ve no idea why. Neither do Naim support. I have had a few email conversations with them over the years, but to no avail.

Anyway, just thought I’d share my experience in case it would work for you, because I know how frustrating it is.

I experienced a problem with a brand new ISP supplied router just a month or two ago. Separating the 2.4 and 5gHz bands meant I could only connect reliably when my iPad was connected on the 2.4ghz connection.
It’s not only very old router that cause issues.
I now use an Araknis router and it works so far.

Yeah, it is tremendously frustrating! It had been rock solid since it came back from the repair at Naim in January. I suppose at least the radio presets on the dial work, and the Pixel provides some level of comfort that I can still stream via Tidal.

I’ll see how it holds up over the next few days/weeks. The messing about with setting on wi-fi doesn’t fill me with joy!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.