Naim app closes when searching

Same problem here since today, Using both iPhone and iPad. I tried restarting ndx2, Core and phone. The search worked on iPad without Tidal. After installing Tidal, it failed on the iPad.

Tidal indeed seems the problem. I uninstalled the app and only logged into Qobuz and problem is gone.

I’ve noticed that, occasionally, after using Tidal, the app (iPhone) won’t stream from a US into a Mu-so. Rebooting the latter fixes the issue.

You are right on my iPad I was not logged into Tidal. Searching in the Tidal app itself works and also on my Logitech server old streaming system it is fine

With previous problems Naim usually responds very quickly. Hope also now, will use only Qobuz for now to search, or search in the app and put it in favorites.

Yes, I started similar Topic recently iPad and iPhone app quitting when typing in search bar

I have copied my experiences below as I don’t know how to merge topics.

Today both my iPhone and iPad are quitting the app when I start typing in the search bar.
iPhone is using version 5.14.4 on IOS13.5.1
iPad is using version 5.16 on IOS 12.4.7
Both quitting the app when I get to four letters in the search bar today and both have previously worked fine. Any ideas?

OK, so now I can see it only happens when i’m logged in to my TIDAL streaming app. If I log out of TIDAL I can type in the Naim app search bar without it quitting. Not much use as I don’t have another streaming account. So I tried the TIDAL app and searches there work OK and can stream to my Mu-so with Chromecast.
I have updated my TIDAL app and run an update for the Mu-so speaker but still have the same issue searching on the Naim app when its logged in to TIDAL - weird

It does seem weird. I will flag this up to @Paul to see if there’s anything we can do here.

Hello…just for information my app on both phone and iPad has started to crash. I cannot use it to connect to my US and Tidal will not search. It was fine yesterday.


I’ll flag this up to @Stevesky

Thanks everyone, We’re looking it in to it.


I have reloaded the app on iPad and iPhone both running iOS 13.5.1. I have restarted my Virgin Hub 3.0 and I have restarted all of my switches. Both apps crash when trying to play ripped CD’s from my UntiServe and when trying to use Tidal and search for music. That just bomb straight out. I can however play radio and use Spotify.


It may well be TIDAL. I have deleted the TIDAL app but it still crashes. The ripped music gives you options at the bottom of the app via TIDAL which crashes and using TIDAL via the app crashes as well

1 Like

Now working again on both my iPhone and iPad with TIDAL logged in. Would be interested to know what the problem/fix was/is.

Don’t think it’s Tidal as it was working earlier. The Naim App now crashes when I do pretty much anything. Have tried deleting, reinstalling and all of the above. Currently using MConnect Lite which I just downloaded and it seems to be working fine, even on Tidal search.


Now working, should have waited 30 seconds, it’s a miracle I tell you!!


All is well now. Tidal’s API was returning phantom ‘infinite items’ in its search results - with not insignificant consequences! They’ve rolled back today’s deployment.
Sorry for the nuisance.


Thank you as always for a very quick response…brilliant service as always and that’s why I buy NAIM.

Love that response

This is why I love Naim!! It got fixed right away!! Thank you !!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.