Naim App doesn’t find Music Files

App controlling NDX 2, MuSo & MuSoQB

I normally run the above devices from Roon (media files are located on a Windows 10 media pc) and that functions with no issues.

Today I tried to set the devices up with the Naim App, using the same network media PC, as an alternative to Roon.
When I select the server option and music folder in the app no artist or album information is detected. There is some 50k of FLAC files with embedded covers & copies of jpg files but none are discovered by the app! Hopefully I’ve missed something simple but I can’t figure what it is.

I have tried connecting the app to a separate backup NAS drive which works perfectly & instantly. I would prefer the backup drive to remain a backup & use the media server as the source for streaming local files.

The NDX is wired to the network via an Ethernet switch to the router. As the devices work with Roon the basic network settings are correct. The NDX displays & plays Tidal streams without problems.

I have removed all shared drives & re-shared them (renaming some to avoid potential naming confusion), reset upnp, reinstalled apps…you name it & I’ve tried it (I think :thinking:)

I have run out of ideas trying to resolve this, any help or suggestions would be appreciated.

If I’m understanding this correctly, is server mode not just for USB devices attached to the streamer? Do you have uPnP software like Asset or Minimserver on the media PC?

Previously, I was able to specify a server path for the MuSo’s and stream my music directly to the individual devices. That was prior to adopting Roon as my main control option, the NDX is a recent addition.

I assume the principle of specifying the source of the media files hasn’t changed, I might be wrong but the quick setup Instructions seem straight forward enough.

Hi, you need to either attach the drive to the ndx itself, then enable server mode which will allow the musos to also play the files.
Or install a upnp server such as asset or minimserver on the device with the flac files attached, and this server will then be visible to the ndx etc.
Roon is in effect a upnp server just using its own protocol to feed roon ready devices or via chromecast etc.
You make reference to a media server, what is this? Is this something running on a nas?

It’s the Windows 10 machine. Some while ago, prior to the arrival of the NDX I seem to recall it worked with the MuSos however l will look into Minimserver as that may be a solution.
That said, the NDX/App can see the existing windows 10 “server“ and the folder structure, there’s just no files visible. There’s plenty of time, at present, so I’ll have a play.

It might be an idea to use the nas as the prime store, and back the nas to something else. That would mean you wouldn’t need a power hungry pc running all the time.

A properly implemented UPnP server can scan your network for music folders. They do not have to be stored on the same device, just available on your network. The server can then scan the folder, read and index the metadata on the files, and make it available to the streamer. In the case of your NDX2 it should then be found in the Server input. (Nothing to do with enabling Server Mode, this just turns on the NDX2 internal server which is not relevant here.)
I suspect your (Windows?) server has not indexed your music library, and perhaps needs to be set to rescan it. Ultimately you may be better off using a dedicated music server like Asset or Minimserver rather than one that is bundled with a PC or NAS.

Thanks Chris, the music data was being indexed but I’m rebuilding the indexes now, one less thing to be concerned about. It’ll take a while, will update here later. Paul

Re-indexing complete, no change. :thinking:

As a test, could you copy a few albums onto a USB drive and connect that to your NDX2? This will appear under Local Music in the Server input, and you can see if there is metadata in a form that the streamer can use.

I really think you’re going to need a music oriented UPnP solution like minimserver running

I have pinged the SSDP group address ( and the win10 machine Is the only device that doesn’t respond for some reason so I suspect there’s a upnp problem which, in theory, is active on the machine.

Thanks to everyone for your suggestions so far…more searching later I need a break/beer :roll_eyes:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.