Naim App fine on ipad, v slow to find upnp servers on iphone

Okay, just got my NDX 2 (after a 6 month wait) and have immediately run into a weird problem with the Naim app. Spent a day scouring the forums for a solution but nothing has worked.

In a nutshell, when using my iphone the naim app takes about 5-10 minutes to slowly find all my upnp servers whereas on my ipad mini the naim app finds them all instantly. I downloaded a free upnp client called VLC on to my iphone and that instantly finds my upnp servers. Both my iphone and ipad are connected to the same wireless network and are next to each other.

I have tried disabling IGMP snooping as this is mentioned elsewhere in the forum and that has no effect.

I have 2 x ASUS RT-86U routers in a mesh network with the NDX 2 wired to one of them and there’s a wired connection between the two routers. I have a synology NAS running media server. I also have SONOS devices connected to the network which show up as upnp servers (for some reason) so these also appear as servers in the NAIM app. On the ipad mini and using VLC on the iphone these appear instantly. On my iphone using the NAIM app they slowly appear one by one over about 5 minutes and the Synology NAS eventually appears after about 10 mins.

FWIW I ran the new self help tool in the NAIM app which just told me that my network was moderate and didn’t come up with any suggestions.

So, in summary:

  • ipad mini running NAIM app = upnp servers appear instantly
  • iphone running VLC app = upnp servers appear instantly
  • iphone running NAIM app = upnp servers appear one by one over about 10 minutes


I have a similar problem but in my case only since the last App update.

The App is very slow finding my UPNP server, so slow that I often give up. The App is running on iPad 5th gen with iPadOS 14. Before the latest App update the server was always found instantly.

What does work for me is, if I restart the router and the server followed by the NDS (not updated with the new firmware as I do not use Tidal ) it does then find it instantly.

Hoping for an app update.

You don’t say what things you tried, like for example have you tried a restart of your iPhone?, have you tried stopping and restarting the app?, are you just sitting waiting for servers to appear or are you refreshing the screen in one of several different ways?

Also do you really mean you have two routers? You should only ever have one router.


I do not have a solution but I also have the same problem since the Naim app update. It worked fine before the app update.
It takes about 15 minutes for the app to find minimserver on my Melco N1. It then loses it again after a while.
I have an ND 555 and two different iPads and I tried turning them all off and on as well as the Melco and router but the problem still exists.
I also updated minimserver and reinstalled the app.

mconnectHD finds minimserver straight away.
I do not understand why the Naim app does not work when another app does work well.
I hope the app can be improved as it is no good for me at the moment.


1 Like

Thanks for all the replies so far. Just to answer a few questions:

I’ve done all the “usual” stuff so I’ve rebooted everything (router, NAS and iPhone/iPad) deleted and reinstalled the NAIM app and, as I said above, tried with a different upnp client on the iPhone which worked fine.

To answer a couple of specifics from davehendon, I just leave the iPhone alone on the servers page and gradually the upnp servers show up. I’ve got an asus mesh system so there are two routers connected with an Ethernet cable. I’ve tried with the iPhone/iPad connected to each router and it doesn’t make a difference.

Everything points to the app but I’m slightly confused because it’s the same app on both the iPad and iPhone isn’t it? As I’m new to this I didn’t have a previous version of the app to know if this is a problem with the latest version.

Does that shed any light on anything?

1 Like

Have you tried a network reset on the iPhone? (Settings > General > Reset > Network Reset.)

I hadn’t but I have now. Makes no difference unfortunately.

1 Like

Which one of these is running as DHCP server? If both you are more or less guaranteed to have network problems so you should disable it on one of them, or perhaps replace it with a device which is only designed to extend your LAN.
Whether this is causing your current issue I’m not sure but either way it’s an issue you might want to address.

The asus mesh system is pretty well established and stable. One of the routers is the “main” router which runs dhcp etc and has the broadband connection, all the others are called nodes.

But hang on. I’ve just downloaded the Naim app on to my daughter’s iPhone … and it’s working fine.

So it must be something to do with my iPhone. Hmmmm, I haven’t updated to iOS 15 as it’s been so buggy but maybe I should do that and see if it helps.

You don’t need IOS15! I’m still on IOS 14.8.1 and it’s fine.

I suggest you delete the Naim app, restart your iPhone and then reinstall the Naim app. If you get asked a question about it using location services, says yes (as searching your WiFi network counts as location services for some obscure Apple reason).

I was already in mid upgrade so couldn’t try deleting the app and restarting but the upgrade has done the trick. Obviously iOS 14 does work (as you’re using it) but something in the upgrade process has got it working.

Thanks to all who helped.


Thanks for sharing this darrens as updating to iPadOS 15 has fixed my issue as well so mine was the same problem as yours.

@IanS pleased to hear that. There’s obviously something really weird going on which can’t be a basic incompatibility (as @davidhendon is using 14.8) but is something peculiar to the NAIM app because other upnp clients work fine.

I suspect this is going to be a really hard one to diagnose so good to know there is a solution for me, you and anybody else having the same issue.

I tried your suggestion to delete the app, restart then reinstall. Unfortunately this makes no difference. Actually after doing this I had to enter the IP address manually to find NDS on the network.

I think another update is needed.

All seems fine on Android 11.

I had the same issues, iPad worked fine iPhone could not see mini server, once I reluctantly updated the iPhone software to the latest version and all worked fine.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.