Naim Multiroom issues, help please!

Looking for some help getting my network figured out, I’ve been in contact with my local dealer for past year or so without any resolution. Any help would be greatly appreciated!

I currently have a Nova connected to 250 DR powering Wilson Audio Yvettes in my main room and 2 Muso QB (one gen 1, one gen 2) throughout the home. All wireless. Wired connection is not an option.

Each device can stream Tidal or Roon (except Gen 1 QB, which isn’t Roon ready) individually without problem. All devices are connected via Wifi. The Nova and QB 2 on 5Ghz and QB1 on 2.4Ghz.

My ISP is a cable connection rated at 500 down 20 up. I use an Asus WiFi 6 router and get strong signal near each of the 3 Naim devices. I have 2 different 5Ghz SSID. One of the SSID I reserve just for Naim devices and iphone/ipad I use to control them. All other 5ghz clients in the house are on another SSID.

Thus far I have reset each item to factory defaults and updated the firmware. I still can’t make it through 5-10 seconds of a song without drops. I use exclusively Tidal and some HD audio files on PC that acts as a Roon Core. Both Roon and Naim app drop signal.

Some other odd things I’ve noticed.

  1. On Naim app I can see both QB and Nova. But when I open the Nova and click Multiroom I cannot see the 2nd Generation QB on the list to select for Multiroom about 80% of the time.
  2. When I start Multiroom from the 2nd Gen QB I can see the Nova. But when I select Nova the app acts like it works, but I get zero music.
  3. Roon is extremely erratic. My Roon Core is hardwired to Network with Cat6. But Naim QB Gen 2 and Nova cannot stay in sync with one another and frequently lead to drop outs.

Any thoughts or tips would be greatly appreciated.


My humble suggestion is to buy some cheap long ethernet wires and temporarily connect all three units to a switch. If it then all works properly - which is highly likely - then you’ll know that you’ll need to get a proper network installed. I have a 272, a UQ2 and two Qbs and multiroom is rock solid.

I’m no expert, but I’m a little suspicious of your network configuration. Different SSIDs, some devices limited to 2.4GHz, others limited to 5. Maybe you need to keep it simple and use your router’s default settings?

My Nova and Muso Qb (gen 1) work happily in both directions using multiroom. The Nova is Ethernet connected via a switch to the router. The Muso Qb is wireless. This has survived a change of router; the first (BT Smarthub) had the 2.4GHz and 5GHz given separate SSIDs; the second (BT Smarthub 2) uses the same SSID throughout. Apart from the tweak to the 1st router, I just left the default settings as is.

Not much help to you perhaps except to prove it can work well.

I agree its a network issue. I’m just not sure what the problem is. Each Naim device can stream on their own without issue. Its when I try to use Multiroom or Roon the system fails.

I’ve tried default settings without improvement. Other things I’ve tried.

IGMP off and On
All on 2.4ghz signal
Wifi 6 on and off
Adaptive QoS with only the naim items and my Roon Core PC having highest settings
I’ve tinkered with radio channels and bandwidth ranging from 20 to 160hz.

Anyone else overcome issues with multiroom? If so what did you do (without running Cat6)?


I’ve ran Cat 6 to my nova. No issues with that now. I also have no issues with Muso QB gen 1. But I still cannot get the Muso QB gen 2 to stream in multiroom.

I launch the Naim app. I start playing on Nova. I select the multiroom button and I can only see the Gen 1 QB. I don’t see the QB gen 2. However, When I open the app and go to select a player from main screen I can see both QBs and the Nova.

Anyone have any thoughts? Did I get a bad unit with gen 2 QB? Since ownership it hasn’t worked and I’m tempted to ask dealer to replace the unit.

Is it possible that due to different wifi distances, one unit is using 5ghz and the other 2.4ghz?
That might be causing issues.
I have made sure mine all connect to the 2.4ghz wifi to be sure there’s no issue.
5ghz has a noticeably lower wifi range than 2.4ghz.

Blythe, thank you.

The Muso QB v2 is closest to the router (20feet maybe) and was on 5g with strong signal. I changed it to 2.4g network and its now working with multiroom. Random that my more congested network is allowing synced playback, regardless I’m just happy it works now.

1 Like

IGMP settings such as ip igmp query-interval may need a review, I.e shortening in duration, with IGMP set to “on”

I am also having Naim multiroom issues. I own a NAC-N 272 and have just got a Muso 2 on loan from my local hi-fi dealer. The Naim app on my Android phone shows both devices and they both work fine as independent units, but when I select the 4-square multiroom icon on the right of the volume bar for the Muso 2 it only shows that Muso 2. My NAC-N 272 is not listed.

Multiroom is turned on on my NAC-N 272 but the search for other streamers fails to find the Muso 2. The 272’s volume bar on the app does not even display the 4-square multiroom icon. Both units have a wired Ethernet connection.

My Naim dealer is struggling to think of a solution. Has anyone here got any useful suggestions?

Is your 272 on latest firmware? 4.7

I assume you have tried restarting your router and your 272 come to that?

Can you get a mate with an iPhone to try multiroom from his/her phone? Some android phones behave in odd ways which is why the android app is less certain that the IOS app.

If it doesn’t work with an iPhone/iPad either then you could try resetting your 272 to factory settings.



Things are no different on my iPad. Given that my failed search for other streamers on the NAC-N 272 was done from the handheld remote, the app cannot be part of the problem.

I’d already tried restarting the 272, but it didn’t help. A network issue seems rather unlikely, as both Naim units can stream music files stored on my NAS. An IP scanner also shows the IP address of both machines.

As it happens, I’m reading your post just after returning from my Naim dealer with a suitable cable to make a firmware update to my 272. My machine is two levels down, but an update never seemed to be a priority as they didn’t appear to provide anything relevant to my needs. The only mention of multiroom (in the description of V4.6) is “Multiroom compatibility with Uniti Atom, Uniti Star and Uniti Nova”. Perhaps that also has some relevance to my current problem, so my next step is to update to 4.7.

Yes I had a vague memory of one of the firmware updates being important for multiroom with the new streamers. I’ll bet that is the problem.

You can go straight to 4.7 from 4.4. No need to go through 4.6 first.



I’ve just completed the firmware update process. It seems an unusually complicated process, but the effort was worthwhile, as multiroom is now working :slightly_smiling_face:


Good! Glad it worked.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.