Naim muso (Gen1) cannot connect

Good evening,

I have searched the forums and have not found a topic that fits my issue (I am not saying there isn’t one).

I have a muso (gen 1) which has been working fine. However, as of yesterday, it abruptly stopped streaming and I could not connect to it. Connection: network port in wall - Cisco router - Muso.
After checking the connection was working I have tried to add the Muso from the app, both by the cabled connection and WiFi,
Turned Muso off and on again - no effect.
Turned router on and off again - no effect
No issues with other devices inc Naim Atom.
Bubble UPNP cannot find Muso either.
Muso status light is white
Looking at my router to see what is connected and we have:

Any ideas good people?

And am I likely to get any help from Naim for this legacy device?

Try turning off both router and muso at the same time. Wait a few minutes, turn on the router and let it fully boot up. Then turn on the muso. The order of doing things can make a difference.

This has happened to me a couple of times. I did all the rebooting and nothing worked. I went to bed, and in the morning it was working again. It’s very weird.


If the above good advice doesn’t work first time, repeat, turning off absolutely everything connected on your network. Overnight is a good opportunity, then restart just router, wifi, streamer and app.
Likely conflict in your router, yes Naim support would likely help, but sort network first perhaps.

You could also try switching off 5ghz wifi.

While posting, useful info - country, which app you use / control point, and what broadcasts your wifi.

1 Like

Thanks for the advice. I will follow it and report back.

Rightho. HH’s advice has not been successfull after two attempts so onto method sound-hound.
Looking at the connections on the router, the Muso does not appear.
One question - I am hard wired in, not using wireless, so why would turning off 5ghz WiFi make a difference?
Router = Fritzbox 7530
Apps used = Naim & Bubble UPNP & Synology Audio Station (DLNA)

Thanks for your help.

Did you try a different Ethernet cable?

When you powered off the muso did you physically remove the plug from the wall for at least 5 mins to ensure it fully shuts down and empties its caches?


Nope - that would involve our taking down our TV and spending an hour putting back up.

I have tested the cable going into the Muso and it works fine.

Thanks. Yes to both questions.

Do you have any iRadio presets set on the dial of your Muso; if so do they play?

Is the issue that your app doesn’t find the Muso? Still no info as to whether you are iOS or Android?

Does your control point connect to the Muso by bluetooth?

If you can’t remove the plug at the wall, turning off the circuit at your main fuse box would have the same effect.

I have no iradio presets set on the dial of your Muso.

The issue is that my app doesn’t find the Muso.

I am Android but also cannot connect through Synology NAS Audio player via DNLA.

I have never connected to the Muso via Bluetooth with the app.My TV connects to the Music fine through Bluetooth.




I can remove the plug at the wall. It is the ethernet connection that is not easily accessed


Hi sound-hound,

Advice followed to the full. No joy yet.

Tomorrow is another day


Pity - I raised the very same question on another thread, only in the last few days!

Try !

Realistically, I think that you have to switch off everything connected to your router. Restart router, switch off 5ghz as I suggested earlier - it maybe your router doesn’t do hand off well, this may be an issue and only restart router, streamer and app. Nothing else.
Why did it work before - perhaps you have auto update on router enabled. It is not a measure as to whether everything else works, simply Muso and your network. You will get there. Make sure you keep a written record of the steps you take. If it doesn’t work, you need to explain all the steps you have taken, when you contact Naim support.

Hi I have now tried to connect through WiFi exactly as you suggest with no joy.
It has been working fine for over a year and a half. It suddenly failed to connect a few days ago. No reason for this that I can see.
Bit of a puzzle.

Update. Tried to set up through WiFi and got as far as ‘transferring settings’ but would not progress further.
Went back to cabled and it now has flashing purple light even when cabled in.
Turned it off. Removed plug and cable and left for half an hour or so - still the same.
Any advice welcome.
Time to contact Naim support I guess. Still works through bluetooth with TV and TV has Qobuz app. So really nice soundbar :slight_smile:

And my Atom suddenly stopped streaming. I then cabled the Atom directly to the router and all was fine.
Then I disconnected it and could connect it to it wirelessly again.
Tried to do the same with the Muso and it did not want to play so gave up, it and put it back on it’s shelf having disconnected it.
An hour or so later, I opened the Naim app to use the Atom and the Muso was there as well.
Absolutely no idea why or how this happened and I am not sure that this thread would help anyone except to say keep trying I guess. Hopefully I will get another year and a half of no issues🙂

Thanks for all the help and advice.


1 Like

Good to hear it is now working. Given you reported a white light much earlier, suggest you assign five reliable iRadio stations to your presets.
That way, if you have problems again and white light shows, you can begin to determine if it is not seen in the app, whist the Muso is playing (or not).

1 Like

If issues do come back, you still have the following options in your armoury

  • Update firmware on router
  • reset Muso to Factory default
  • reset Router to Factory default
  • Try an old router if you have one
  • Try and get a replacement router
1 Like