Naim Muso V2 Issue

Hi everyone

I have been an owner of the Naim Muso V2 since January of 2020, and I am a big fan of the product and it has worked rather flawlessly since I first set it up. However, just yesterday I began experiencing a sudden issue where no sources/inputs will play back any audio whatsoever, including HDMI and USB sources. I am a bit confused as to how this happened and I haven’t been able to use the product at all since. I have tried turning the device on and off again, but it does not appear to be helping after several attempts.

I can tell the device has a working connection to my network, because I can use the Naim app to put the device in standby mode and turn it back on. Internet Radio from the Naim app does not work, Airplay playback can see the Naim Muso V2 as a device, however no audio returns. I have also retried resetting my router which has not helped either. I primarily use the device with Roon, which I attempt to start playing a track and then it immediately stops saying ‘Audio Device Refused to Switch Input to Roon.’

I’ve even tried factory resetting the device, however I believe I am not doing it correctly because it doesn’t wipe the latest firmware and when I go to re-configure everything, I cannot get the Naim Muso V2 dial to stop the lights from spinning, with the color staying orange and never goes any further with an Ethernet connection. Any assistance in this would be greatly appreciated.

Have you tied to unplug it let it sit for a few mins and plugging it back in
Failing that try rebooting your network

All I can think is that your network is having a moment. The order in which you reboot things can make a difference. So turn off your router and the muso. If you have a network switch, turn that off too. Then turn on the router and let it fully boot. Then the same for the switch if you have one. Finally, turn on the muso.


Factory reset doesn’t wipe the latest firmware. It keeps the currently installed firmware.


Thank you, I will give that a try and report back.

David, I guess I just assumed that the firmware would reset as well. Thanks for that clarification.

1 Like

Alright, after following the steps as HungryHalibut outlined, when the Muso is re-connected back to power, I get an orange status light indicator and the spinning light again. It seems permanently stuck in this mode, despite being connected via Ethernet and viewable on the network from all of my other devices. While in this stage I have unplugged and reconnected the Ethernet cord directly from the device undercarriage, but this appears to have no impact.

I’m not sure what else I can do, outside of contacting Naim support, which I have just done.

That’s a shame. I know you said you’ve factory reset it, but have to stuck the pin in the little hole and reset it that way? Maybe worth trying again?

1 Like

Had a similar issue with a friend recently.

They had upgraded their WiFi hardware and extenders, and during the setup had enabled Mac address filtering.

This meant the Naim was visible, but not allowed to talk to anything.

As soon as the feature on the router was set back to default (Disabled) everything worked again.

Worth a look at your router/WiFi settings.

Hope this helps.

1 Like

Interesting suggestion, thanks. After tinkering a bit, I found where this appears to be controlled, even though my router administration page doesn’t specifically call this MAC Address Filtering. It appears the device via Ethernet is already allowed. Curiously, further down it lists the Wi-Fi as not connected, but still allowed. I tried disabling and re-allowing the Mu-So, but this didn’t seem to have an impact.

Somewhat strangely, the MAC address differs in the last digit between the currently connected device and the one that is shown unconnected. Is this the same Muso? It’s unusual that the MAC address would change at all, and in particular if only one digit changes.

Just to be sure, try to uncheck “Turn on Access Control”

1 Like

That is interesting, but I wouldn’t really know enough about MAC addresses to know why that’s the case. It should be the same Muso I would think, I do not have a second. Unless it was somehow duplicated during my few factory reset attempts.

It does look like I can manipulate the MAC Address of any of these devices, I wonder what would happen (if anything) if I attempted to match the unconnected Muso address with the currently connected one.

I have tried toggling Access Control on and off a couple of times now, does not seem to be helping the issue unfortunately.

These suggestions have all been very informative, I appreciate it.

The MAC address is a random number that uniquely identifies the network card. Each MAC should exist only once in the world. The manufacturers of network cards are assigned blocks of MACs and they bake them into the cards. It can still be changed, either by the operating system or directly on the card with special tools, but I don’t expect this is possible on Mu-sos for consumers. So it’s strange that there are two different but similar ones. I doubt that a factory reset changes it.

Your router lets you manipulate which MAC addresses it allows access, but not the MACs that your devices really have. If you change the address of the connected Mu-so to the one from the unconnected one in the router’s list, nothing bad will happen. Either the addresses match and the Mu-so gets access, or not

However, as it does not work after you generally turn off the Access Control, this doesn’t seem to be the problem. (In general, MAC address filtering has very little to no security benefit, so it’s questionable if it’s worth bothering with the complexity)

Can you successfully send a ping from your PC to the Mu-so?

1 Like

Yeah, it looks like I can ping from my Mac. Hadn’t done this in a while, so had to remember the steps. Below are the results. Typically takes less than 2 milliseconds.

Looks good. So the Muso is allowed on the net just fine

1 Like

True, but it makes the issue all the more puzzling. I’ve tried factory resetting a couple more times, however it always seems to get stuck right after I turn it back on after the reset completes. The dial just spins and spins and never moves from an orange color. My gut is telling me this is something super simple I’m just not thinking of, but I find it extremely odd that even a file on a USB drive won’t play back at all.

I’m hoping Naim support can get me back into working order here.

It does seem like a hardware problem :frowning:

Hi there, I reached out to support@naimaudio regarding this issue on September 8th and I have not heard back yet after the ticket was generated. I do see the note regarding delayed response times that appear to be 5 business days, however I wasn’t sure at what point I should try calling instead?

Could you please tell me your ticket number and i’ll pursue it for you.

1 Like

Hi Clare, the ticket number is 120141. Thank you!

If it’s easier to phone instead, I would be more than happy to do so.

1 Like

I’ve flagged it up to the team - whom are, of course, also happy to take calls.

EDIT: they are on the case and will be in touch ASAP.

1 Like