Naim NAP 300 + 300 DS - Power Button not remaining "on"

Hi!
I have recently bought some Naim equipment - among them a Naim NAP 300 + 300 DS. I have some issues with the 300DS. The power button on the front side doesnt “remain in on position”. I need to use some strong tape that I tape in a cross pattern in order for it to “remain on”.

Anyone of you that have experienced the same thing? Is it a difficult thing to repair? I live in Stockholm Sweden.

Marcus

If the switch is not latching properly then it can be down to either needing adjustment or replacement.

First though, disconnect the 300PS from the mains power and try pushing the switch in and out a few times with something like the eraser end of a pencil. You may encourage it to latch. However, if not, then best speak to your dealer or distributor. Hopefully it’s something that can be fixed locally in Sweden rather than needing to go back to the factory.

1 Like

Just out of interest, why would it need to be done with the eraser end of a pencil?

Hi @Marcuzo, I had much the same issue with my NAP300PS, I found that exercising the switch from the front didn’t help, but if you are confident in removing the case/sleeve operating the switch component its self directly inside a dozen of so times solved the issue for me and it has not repeated since.

Remember to unplug the unit first.

You don’t want to use tape, as the button may not be properly ‘on’ and it may well leave nasty sticky residue on the front. Have to tried giving the button a very firm poke with your finger? Not a press, more of a quick jab.

Hopefully that will do it. If it doesn’t, it’s an easy fix to fit a new button, which is something your dealer may well be able to do themselves.

“Remember to unplug…”? Really?:smiley: or should that be :weary:?

Because sometimes the failure to latch is just because the button isn’t quite pushed in far enough. The eraser end of a pencil should allow you to push in the button a little further than just by a finger. It also allows you to more easily “jab” at the button, as mentioned in HH’s post. If it then latches you then know the problem and it may be fixable through simple adjustment by the dealer.

1 Like

Thanks!

What do I need to remove the case/sleeve? Any guideline available or will it be obvious when I start?

Did you buy new equipment or used (and older than the standard warranty)? If it’s still under warranty, opening the case might invalidate the warranty.

1 Like

The switch is highly likely defective and needs replacement. Same for my XPS2, 300PS and Hicap2 from 2004 that were all serviced last year with the rest of the equipment SC2, 252, 300, CDS3 where I asked for all power switches to be changed as part of the servicing. The new ones seem different to the originals.

Remember if you do take the case off, that the capacitors inside may well still have a charge - so watch where you put your fingers

If you need to ask how to remove the case, you probably shouldn’t be thinking of it. Try a good hard jab or two, and if that doesn’t work get your dealer involved.

2 Likes

Is this a negative effect of many Naim components being always on so the mechanical switch corrodes or something? :man_shrugging: