Naim NSS333 not playing Tidal

Full 300 series system here on review and for the past couple of days the NSS333 won’t play anything on Tidal - only local rips. Internet radio doesn’t seem to be working either.

After a while the album art of what should be playing is displayed but there’s no sound (it’s worked perfectly for a month or so) leaving me baffled.

It strikes me this could be an issue at Naim’s end and their link with Tidal but if there is a problem I can’t believe I am the only one posting on here about it!

Obviously I have rebooted iPad and streamer, checked connections and confirmed that my tidal subscription is live and working.

Am I the only one with a problem?


Don’t use Tidal much but checked an album not on Qobuz and appears to be working okay through Roon on 200 series NC

No issue with Tidal playing on NSC222 - in uk. Is that where you are based?
Useful to highlight a specific album not playing, to allow others to check.

edit - see you also don’t have iradio working. Try factory reset of NSS333?

Try to change the password of Tidal and disconnect first Tidal from all your devices. It had worked for some.

Thanks folks, I will give those suggestions a try - at least I now know it’s an issue for me here…

Wishing you all a Merry Christmas and happy and healthy 2024…


A router reboot fixed it! I have to say I was forced from John Lewis broadband (BT) on to an alternative provider as John Lewis were leaving the market. I selected Vodafone and since then I have been finding their supposedly equivalent service (top tier) less snappy.

It is costing me just £21 a month though instead of nearer £60…

It’s been running about a month until for some reason it caused this problem with Naim. At least I know what the fix is now - I wasted over 2 hours troubleshooting yesterday never thinking it could be router related because I could still play local rips from my NAS…

Anyway on with Christmas…



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.