NAS drive compatibility

First post, so go easy on me!

My system comprises a NAC-N 272 with a NAP180 power amp in one room, and a Unitiqute 2 in another. Music comes from a Synology NAS, with an old WD MyBook NAS as backup. I’m on BT, and had been running a Netgear Nighthawk router.

Due to spotty connection, and a series of attempted cures with power lines, extenders and whatever, I went for the BT Complete Wifi package, with 3 discs around the house. Early days, but it seems to have done the trick in terms of signal strength and reliability.

The problem is that the router can’t see the Synology, which is connected via a short run of cable to a Netgear unmanaged switch, which is then connected directly to the router by around 15m of cable. Everything else on the switch (blu-ray player and the Unitiqute itself) is working fine, and the router can also see the WD MyBook. I’ve tried connected the Synology direct to the hub with no difference.

The main purpose of the Synology was to run Asset for FLAC to WAV conversion on the fly. I don’t think that Asset (or MinimServer) can be installed on the WD. I’ve had a look around online and I think the Synology is just not compatible with the BT router.

I can live with replacing it, as I can reuse the drives and am just losing the cost of the box itself. What I’m wondering is if there is a tried and tested NAS that will work with the BT hub out of the box. I’m technical enough to go poking around in settings, but not when it involves delving into command codes and whatever. And I don’t want to run a separate router as the hub is doing its job as a mesh network.

Thanks in advance.


Welcome to Naim w33logic

I run a Synology with BT - BT HH6 into a switch & NAS-switch-NDX and it works perfectly, I’ve used the Synology connected directly with a BT & it too works perfectly, so forget the idea that Synology & BT are not compatible, too many people everywhere have that combo.
I suspect your problem is with your Netgear router & am wondering why you use a 3rd party router, the BT Smart Hubs 1 & 2 are some of the best available. I suspect its because the Netgear has a problem with IGMP network issues, it probably has some setting that can address this but I don’t have any experience of this.
Do you still have your BT issued hub, if so hook that up & check it out.

Hi Mike, I’m using the latest BT Smart hub 2 router, which has replaced the Netgear. Are you aware of any settings you changed at the BT side to get your NAS working? The system uses dynamic IP addresses so the address the NAS had on the old router has changed. I’ve tried mapping my network but can’t see an IP address for the NAS anywhere now.

The BT HH6 has no settings to change other than some customer preference stuff. its deliberately made so to minimise customer making unwise settings - its almost plug-play & forget.
Good to have dynamic IP addresses, this is DHCP & is the right way to go.
Next question is - how is the Synology set up, it needs to be DHCP. as does everything else on the network.
Double check that it is indeed all DHCP on all the network. Then turn it all off including the router & switch, leave it off for 5 minutes, start the BT first, let it finish, next start the switch, then the Synology, then the rest of the network one at a time.
That should allow the Synology to show, if it does not, the problem is in the Synology & thats what you need to work on.

Mike, thanks for that. I’d read too many tales of incompatibility… I’ve factory reset the Synology and it’s showing up with an IP address now. I’ll need to rreinstall a few things but I can live with that. I’ll confirm once all running correctly.

1 Like

Hi Mike, the factory reset of the Synology did the trick. Many thanks.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.