ND5 XS2 & Synology NAS


Having some troubles with streamer.

I cannot find my NAS music servers on the Naim app. I cannot find out how to provide a link. It seems to be automatic.

I set up the Naim Streamer with wifi, but when I later connect to my wired network to see if this finds the NAS, the app cannot find the ‘room’. I seem to lose the device when hardwired, but it is found again when I disconnect the CAT cable.

I would prefer to run over CAT cables as I have a lot of devices already connected over the WIFI.

If I run the set up again, it tells me that its already connected via wifi and won’t let me add a wired connection.

I have a Synology NAS. On it I have music server and Minimserver running. I can stream music using the Synology apps on my phone. Not sure how to test if Minimserver works.

Any ideas would be welcome.

Lastly - which is the best post on what music formats to use with the NAS. Pre Naim I burned everything using Apple Lossless. What is the best format to use?



I think the problem is with your network rather than the streamer and it sounds like you have two different subnets going on. How is your network configured?
As for file formats, my preference is flac which is transcoded by minimserver to wav. On a ND5 XS2 I couldn’t tell the difference in sound but letting the NAS do the work rather than the streamer seems sensible to me. Apple lossless should be fine too so perhaps consider transcoding that to wav in minimserver as well.
As for how to tell if minimserver on the NAS is working OK, try an app like hi-fi cast on your phone and see if the minmserver upnp server is shown as an available source

1 Like

Ummm… good question. Networks are not my preferred part of the technology stack. I get up to speed on a need to basis and then quickly forget.

How do I check this?

These things normally sort themselves out provided all your devises are set to DHCP.

How do you have them wired ?? NAS - Wireless Hub (Router) - ND5 ??
If that is how, I would first try a complete power cycle (turn all off & turn on again)

Turn everything off & leave them off for at least 5 minutes (to be sure your ISP service logs that its off)
Power on the wireless hub first & let it finish its start up procedure
Then the NAS & le it finish
Then the ND5
Finally the Naim app control point - tablet/smart phone

If that doesn’t work, it needs a deeper dig.


It’s a little more complicated. I run a Netgear mesh wifi that is connected to a Netgear 24 port switch, which also connects to a Vodafone router for internet.

The Naim connects fine to the internet and services such as Spotify.

I have a static IP address, so not using dynamic IP addresses.

On VLC on my phone (for example) I can find my music folder on my NAS by manually connecting to the server through the NAS’s IP address (eg This does not come up as a default music server, it needs to be manually connected each time.

I would have expected to find somewhere to manually enter the server address in the Naim app, but there is no facility.

I have tried power cycling and this does nothing.


Which device is running your DHCP server? Is it your router, or one of the Mesh boxes? Hopefully not both!
I would try setting your NAS to receive a dynamic address, restart everything, and see if it’s then discovered.

DHPC is specifically designed for home user, so why not use it.
Set the main router to be the DHCP server so it alone manages IP addresses, set all the rest, Naim, NAS & control point to DHCP, power cycle all in the router first sequence & that should sort it.

1 Like

I’ve tried various changes but don’t seem to be having any luck. I did install Minimserver on my iMac which the Naim picks up, so slowly eliminating issues.

Question @Mike-B

What is the main router? Is it the Vodafone router than receives the internet signal and delivers it to the Netgear switch, or is it the Orbi router that connects everything on the wifi network (inc Naim) plus has some items connected via Ethernet?


If you’re using the Orbi as a range extender & you have not disabled its DHCP function, you will have IP conflicts.

Assuming the Vodafone is the incoming broadband devise, it should be the DHCP IP address & network manager & the Orbi’s DHCP server function disabled.

1 Like


No, I have the Vodafone wifi turned off. It provides internet connection to Orbi via ethernet. The entire wifi network is provided by the Orbi mesh satellites.

The vodafone is set as a DHCPv4 Server

The Orbi is set to obtain IP addresses dynamically from the ISP

The Synology NAS has the DHCP server disabled. PPPoE and IPv6 Tunneling are both disabled.
IPv4 was set to automatic network configuration, which I changed to manual (see screen shot).

Should the IPv6 bet set to off or manual instead of automatic (see screen shot).


I’m struggling with this as not familiar with your routers, maybe Netgear experts are better for this.

Re Synology, I don’t have “Alternative DNS Server” IPv6 enabled

1 Like

This doesn’t sound right, surely the Orbi should use the DHCP server on the Vodafone router to allocate IP addresses for devices on your LAN?

1 Like

isn’t that the same thing? The vodafone DHCP server sets the IP addresses and the Orbi uses them?


Thanks for your help

You said that the Orbi is getting IP addresses from the ISP. Devices on the LAN should get them from the DHCP server on the router

1 Like


Yes that’s what I meant. Everything should be getting their IP addresses from the DHCP server on the vodafone router.

However you made me think that both Routers show a list of connected devices with their IP addresses, so it made me think about an earlier comment about both running DHCP servers despite me thinking they weren’t.

I found some netgear forums that lead me to this article that hidden away in the advanced settings is the ability to change the Mesh to an access point (AP).


Once I did this, the Orbi reset and now I have both the Minimserver and the Synology Music Server on my Naim App.

Problem solved. Hopefully this will help someone else with the same issue.

Thank you all.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.