ND555 won't play Qobuz or Tidal

Delete the app and reinstall?

1 Like

Why not delete then reinstall the network on the NDS, before doing a full factory reset.


Not sure what you mean by delete the network…

Are you using wired or wireless connection? You can use the remote to delete the network connection (forget). Then reboot and set it up afresh as you did on first purchasing.

You can also delete the NDS555 from the app then set it up again. This might be worth doing if you think it is the app communication that is the issue.

Have you actually tried playing the ND555 via the remote? Stick some tracks on a usb to do this.

Does the screen suggest you are connected to Tidal? What does it show?


In the app there is a network settings. You can delete them I think. Then rejoin your Wi-fi

Basically reset the router, ND555 and the app in sequence and set each if them up as per when new out if the box.

I’ve restarted the router a couple times. I’m on a wired connection. Nothing to delete. App is communicating for every function but Qobuz
and Tidal playback, the remote works fine, controls what it’s expected to with every source but Qobuz and Tidal.

I’ll try deleting and reconnecting the 555 from the app.

Thanks for all the suggestions!

Do you have a switch between the ND and the router? If so, try to cut the power for the switch and re-power it.

Also, try to move your ethernet cable that you plugged into the ND over to a computer and test if you have connection.

Can the ND connect via WiFi? If so, try that instead of the ethernet cable …

Do you have other cabled devices on the network?

I am connected to the ND555 from my phone’s and computer’s Naim app. Every aspect of the app functions as expected and I can see my albums in Tidal and Qobuz and select tracks, they just don’t play.

No switch between ND and router…we don’t have any computers with ethernet ports…same results with WiFi.

Whelp, I’m stumped! Tried every suggestion…maybe it will heal on its own!

I appreciate all the help!

It’s odd…If I’m streaming via Roon, but then switch to the Naim app and attempt to play a song from the Naim app, the ND switches to the song I’m trying to play–playback on Roon stops, the song on the Naim app displays the track but doesn’t play–the play button remains the triangle, then when I tap the triangle it changes to the pause button as expected and shows the sample rate info for that song…it just doesn’t play…the time line doesn’t move.


The app can also control the 282 volume and mute functions as expected via system automation.

Just to share with you how such thing usually work - just for your information:

The Naim App on your phone connects directly to Tidal and Qobuz, you browse and surf through your music directly on the Tidal / Qobus servers … whenever you want to play a piece of music the link to the music is passed on to the ND and then the ND connects directly to Tidal and Qobuz to fetch the music data. Then your phone is not a weak data transfer link. That means you can search and find all music on your phone, but when playing the music the ND goes through the cabled connection between your ND and the router, then out in the world.

So, if playing the music on the ND is a problem, then there is a problem somewhere on the way between your ND and the data on the server in the other end (Tidal and Qobuz). Could be login, could be a cable, could be your router not letting the ND through, IP address conflicts, DHCP problem, etc.

Playback on your phone, the connection goes directly from your phone to the end server at Tidal and Qobuz (not involving the ND) …

Hope this gives you an overview that may be useful.

I understand all that, but I appreciate the effort!

I’ve already gone through all of the potential issues you suggested, appreciate it!

1 Like

Can you log in to your hub to see if it’s blocking the ND in some way? It seems it’s the connection of the ND to to outside world that is the problem.

It works! Left the house for a half hour and now that I’m back, it works fine.

Thank you all for your suggestions! Perhaps one of the suggestions did the trick and it just needed some time to settle back in.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.