NDS and Tidal frustration (big time)

The 4.8 firmware update release serves as a timeline to this problem. By way of introduction I’ve spent over 30 min trying to get Tidal to play on my NDS. It worked fine 3 hours ago. This is a constant reoccurring problem. I thought the recent Naim Tidal updates had solved this problem. This evening the past solutions which incidentally didn’t make for an ease of use pleasant experience haven’t worked.

I select an album from ‘my collection’ Tidal says ‘x’ number of tracks added but no joy playing them. Go to iradio and back into Tidal and you could play the album or playlist. But not every time. Sometimes you’d need to toggle between the two and other times switch off the NDS to get it to behave. I’ve had the NDS since May this year and no problems originally. An hour ago I was looking forward to a late evening of music. But alas I’m totally p::sed off with the whole thing. My only saviour is the 256gb stick plugged into the NDS which will hopefully play sum music!


Are you using the android or IOS app? Are you certain you are on the latest version of the app? Is your NDS connected by cable or WiFi?

Hi Mike,

It sounds like a disconnect with the TIDAL server. We’ve found this can be a simple fix for this issue:
Log out of TIDAL on the Naim app. Log into TIDAL’s own app/website, change the password, and then log back in with the Naim app.

A fresh connection is created with the revised password.

I would also ensure you are on the latest version of the Naim App, as per above advice.

1 Like

Claire/David, thank you for your responses. The NDS is wired to the router and I’m using iOS. The password reset seems to have fixed the problem. Thank you.



Good news! Thanks for letting us know.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.