NDS "can't play"

I’m usually play music from tidal and I’m quite pleased with it.
Recently, I’m experiencing a very strange problem, a specific albums just “can’t play” through my NDS.
I’ve tried to restart the Nd, the router, the Netgear, and also tried log out from tidal, and unfortunately it did not work! the same specific albums just refused to play. the display screen on the NDS shows “can’t play”.

I would appreciate your suggestions to solve that fault.


Have you updated your NDS firmware recently? The current 4.7 firmware includes a fix for the problem that stopped some Tidal tracks playing after Tidal changed the format they used in some cases (I forget the detail but anyway your NDS needs to be on firmware 4.7).

I’ll check that. as far as I know, I’m running the 4.6 version…I will Iet you know

I would certainly try the 4.7 update, although for me, 4.6 seems to work OK.
It’s not unusual for albums to stop working on Tidal, in which case they are greyed out, so you still see them, but they won’t play. (Caused, I think, usually by disagreements between Tidal and the artist/record label). I’m not sure that this is your problem, but still one to be aware of.

I’ve update to 4.7 - and play!
Thank you!

1 Like

Excellent news! Thanks for letting us know.


This update fixed an issue I had with the Tidal app not playing new playlists & albums.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.