NDS losing network connection often

Hello, in my experience, as any internet box, a network reader needs a regular restart. I have experienced Marantz, Lumin and Naim. Sometimes, the network reader disconnects. My beloved NDS always disconnected often, although it has been (from the first day) cable-connected to a switch itself cable-connected to another switch that is cable-connecteec to the internet fibre box. The frequency of disconnection has dramatically gone up as it disconnects ca. each 2 hours. I let it work hours a day. Hence, my assumption is that network connection is performed by a chipset that is getting lazy with time… I wonder whether a service and repair will change things or the best path is to go to ND555. Any advice on this matter?

I don’t see the logic in having major issues with a brands network player, so then let’s get the more expensive network player from said brand.


The logic would be: next generation chipset thzt manages network connection has solved issues. Only an assumption. I have been in the IT and computing business for a long time. The assumption may be totally wrong but it is not a total nonsense.

I would temporarily try a very long Ethernet cable and connect your nds direct to the main switch in your system. Either the router (fibre box) or the first switch after that. Just to rule out any issues with the switches and connections.

Loosing connection is frustrating, but best to work through logically.
First follow the advice of @robert_h - simplify your network.
Second confirm what firmware you are running on your NDS.
Third detail what is streaming when the drop out occurs. NAS, iRadio, streaming service perhaps?
Under iRadio the apps have a list of Naim’s choice. Choose one from the list, Naim radio or a BBC feed, all of which in my experience are reliable. Does the issue happen when streaming one of these?

I have a Superuniti which is the same generation as NDS. Mine is in a second building connected via two switches and a long run of ethernet cable. In the main building other streamers and my control point always sees all and each can multiroom according to the selection made. Unless you have a faulty streamer, then dropouts likely occuring in your network. Your router should have a log - does that give any useful details?

Second: I run the last Firmware version 4.8 duly installed in September 21.

Third: it occurs with Qobuz streaming as well as with Uniti Core and in the very same way; iRadio I use very little. I could test iRadio. Uniti Core is linked to NDS via EE 8switch, not SPDIF.

First: I am away from home until May 3rd and will then restest. However, I started with NDS direct to Internet box, I had frequent drop out. I added a Cisco 29XX switch, no change in the drop out frequency. Plus I topped the whole with a EE 8switch and then again same drop out frequency. This is only recently that drop out has gone up to once a day and even each 2 hours.
All Flac files. Limited to 24/96 on Qobuz.
I will check again thoroughly all steps.

Nothing to do with it but SQ is not fustrating at all!

Maybe not a detail: display is out of use.

What @robert_h says.
My NDS never looses it’s network connection.
Then again,no fancy switches in play,just a long network cable to the router. My guess would be you have a network problem. Nothing to do with aging chips in the NDS imho.

Interesting. Do you use your NDS much?

Another location, I have another system. Intenet box-cable-EE 8switch-cable - Lumin S1. The network reader does loose the network too one a week. This not fibre but ADSL. Same provider Orange.
Both locations, I have TV on internet. The TV box has to be restarted. Bouygues fibre and TV boxes at a friend’s disconnect sometimes too. In my experience: my local Ethernet is stable but not the Internet connection.

If your broadband is unreliable then some router designs will automatically restart in order to try to recover the broadband. While they are restarting, you lose connection to anything streaming from the internet, but you can also lose local streaming from a NAS or the UnitiCore. It does depend on your network design though.

Once the router is back on line, the connectivity may be automatically restored, but my experience of the legacy streamers is that since about firmware 4.4, you often have to restart the streamer for it to work normally again after a router restart. I reported this to Naim at the time, but they were unable to replicate the issue, so it was never fixed. This need to restart the streamer doesn’t apply to muso 1/2 or the new Uniti, nor I think to the new platform NDs either, so it’s just legacy unitis and streamers.

Thank you David.

Yes,it’s my main source. Used on a daily basis. But no problems with my internet connection. Rock solid. Maybe that’s where your problem is.

What do you mean when you say NDS is losing the network connection? Do you lose the room on the Naim app? Or is it something else? If you’re losing the room on the naim app I’ve been having this problem since 4.8 but it’s not particularly frequent and usually follows certain sequences in the Naim app.

I’ll Echo @SneakyPete on this. My NDS is a 2018 or 2017 model, the last year they were made, and I’ve never had a dropout or random disconnect. So it’s got to be a network issue, or maybe your NDS is faulty. Wish I had more helpful info, it must be frustrating.
Best of luck.

Well… Fibre internet in France, I have experienced 2 of the 4 offerings in either Paris or the countryside. Orange and Bouygues Tel. Internet drop out occurs daily on the one hand and network perormance is variable on the other hand. And probably in order to refresh all network parameters, it is smart to switch off internet and tv boxes once a week and then let the internet box boot and only afterwards tv box and audio switches.
I have been having the pre-loved NDS (2013 or 2014) for 5 years and it showed network instability from day one. I will run all tests even if I doubt that any switch after the router brings any problem.

Yes, this is losing the NDS Room on the Naim app with the message that another device is connected the NDS room whereas there is nobody else using either Naim app or mconnect from another device. Prior to 4.8 the message was different. If I stream Qobuz on mConnect this is the app stopping to run and indefinitely looking for the file to play.

I could live with it. My concern is PS555 DR must be full of electrolytical capacitors and those do not like to be switched off and on everyday I am afraid… My system is not far from perfect when it plays with this ennoying problem.

David, would a Uniti Core BNC/BNC connection to NDS change things please?

That would certainly allow the Core to continue to serve the file you have already selected and so the music would continue. But you would still have the problem that your NDS would disappear from the app (whereas your Core might disappear but would reappear). And of course it wouldn’t help if you are streaming from the internet.

But you shouldn’t be seeing the message about another app being already connected and that is nothing to do with the NDS. Have you tried stopping and restarting the app when you see that message?

I wouldn’t be concerned about the electrolytic capacitors in the PS555DR. It won’t worry them if you turn the PS off so as to restart it. The PS components will already be warm and so the inrush current will be relatively low.

When I have this message, this is always that the NDs has disappeared of the app. Sometimes I have to reboot the iPad I use to pilot the system. this iPad is over 5 years old now and it may be ageing. Closing and opening either Naim app or mConnect HD never changed anything. I will however retry it.
Thanks for the information that I am not destroying the PS555DR !

If MConnect HD is also losing sight of the NDS then this isn’t a Naim app problem. And if your phone is still connected to WiFi with web browsing working during a drop out, then it’s not your router restarting.

Did you try a factory reset of the NDS? It should have been factory reset after the 4.8 firmware upgrade, but anyway there would be no harm to try it again now.