NDS problem: Another app connected disconnect other client and try again

Still all good. I’m off work this week so system is playing a lot day and night. From memory it was happening at least every hour or so before.

I had the same issue on my 272. It is on the same home network as my Mu-so. I had to pull out the power cable of the Mu-so and then power it up again and the issue was solved.
My legacy streamer still plays up, however. The 272 vanishes from the naim app at times. It reappears when I power it down. I have to do this 2-3x a week.

Same problem here too. NDS latest upgrade, Ipad latest IOS.
Sometimes the app freezes too. Solving this with a restart of ipad.
Daily Tidal stop working. I been streaming with same set up for 6 years, but only last half year I got these issues. Very annoying.

I haven’t had the ‘another app connected’ error since so I’m pretty much certain it was being caused by the other device, an iPad.

I’m now going to reinstall everything on the iPad but ensure ‘stay connected’ is OFF on both devices.

Big mistake reinstalling on the iPad. The problem has come back with a vengeance.

So the Naim app is installed on both iPhone and iPad. Neither have ‘Stay Connected’ ON.

Trouble all day. Closing app on the devices doesn’t help. Lost count of the number of times I’ve power cycled the NDS. It even happens when the iPad is powered down.

Deleted the app from iPad again so hopefully no further problems…

It’s odd because most people don’t have this problem. For example I have beta and release apps on my iphone and my iPad and the release app on my wife’s iphone and her iPad. We use whichever app comes to hand for whoever wants to control something and we don’t ever get this problem. That’s with four legacy streamers, a Nova and a muso Qb.

I agree it’s odd. Deleted the app from my iPad and I’ve not had a problem since, that was a few hours ago.

are you losing the room on the app when the error occurs? Or are you just getting the message another app is connected?

No I don’t lose the room

ok, I get those messages once in a while and just closing and re-opening the app allows me to use the app.

@Stu299 I hope this helps, but this may not be a new issue or confined to NDS, but to the legacy streamers and not even directly Tidal.

Legacy and next gen streamers here. Multiple control points, example iPad 3gen 15.3.1 and app 5.23.2 together with iPhone 12 15.3.1 and app 5.23.2

iPad to SU and iRadio playing, the iPhone immediately gets the message “Another app connected” when the first control point (iPad) still has the Naim app full screen - not when minimised.

Naim app on rooms view on iPad, when the second control point (iPhone) connects to SU, the iPad then flashes up the error message.

IIRC this has always been the case with legacy streamers and two control points. Much of this likely covered on the old forum format, which may not be discoverable using search.

Briefly repeated the exercise with Tidal playing, I can every time, with two control points in use, get the same message, when connecting to legacy streamers. Legacy streamers on ethernet, for control points, both side by side and connected to same WAP, back hauled to switch.

Checked with a UQ2 - same error message when using two control points. Both control points “Stay Connected” = ON - not altered.

Set the control points at my ND or Nova, no connection issue.

@davidhendon has outlined the method I also use, simply close the app on one and press “Try again”

The error message relating to legacy streamers and two control points only occurs when the first control point is full screen, if minimised rather than closed, the second control point will not in my experience return the message. Checked with iPhone on wifi - iPad changed to wired network connection (not wifi), all same behaviour.

Clearly if it is occurring with only one control point in existence, there is a further issue.
If it happens over hours, it may be that either the IP address is changing, or the band is switching between 2.4 GHz and 5 GHz and the earlier connection is not dropping.
Others will have much better knowledge on this point. My hunch though, nothing more, is that with one control point, the network release which should occur, for example as IP address changes, is not happening, giving the streamer / control point the impression that “two” control points exist, when one is a phantom. Just a thought.

Maybe @Simon-in-Suffolk , who has excellent technical knowledge on networks can explain or suggest how to resolve the frustrations some owners are experiencing on the phantom issue.


Thank you sound-hound, really appreciate you sharing your knowledge and expertise.

Since I deleted the app from my iPad last night all is good again.

I think I’ll just leave it installed on my iPhone, which is always with me anyway.

Apologies, I saw this thread a few days ago, checked out what happened with the legacy streamers and then didn’t have a chance to post. I recognise these issues are frustrating, when it can be recreated by others, maybe it shares the pain. Hopefully Simon might add some network wisdom.
As a matter of interest Stu, are your iOS control points able to run Apple’s latest fw versions? I didn’t think to try an older iPad and i have an older iphone, just used for music.
Perhaps you could detail your control point fw and models.

1 Like

If you have the app open in two phones/tablets, then of course it will give you this message with legacy streamers. It always was like that and is well known, mostly.

Ah OK thanks I was late on the scene and didn’t realise :+1:

David, yes indeed. What seems to be happening is the “ghost” issue, when some have reported, only one control point being used and experiencing the error message. I would have linked back to the old forum if it was easy. Totally agree.

I really don’t think this has anything to do with your home network… which would appear to be working correctly… this is service control, and will be likely down to the Naim streamer software interacting with your two Naim host control points… or not as the case may be. Resolution if it exists with these Naim products likely lies with Naim support.
I thought the legacy streamers were only able to work with one Naim app control point at a time reliably. I am not sure those Naim streamers were designed to be multiple concurrent session… but again Naim can confirm. Again it may also be possibly how the products negotiate connectivity with each other… so might vary between home setups… but this is speculation.
In theory the underlying protocols allow concurrent access… but as I say it’s more to do with the Naim software itself.

Simon, apologies if my post / question was misleading. I don’t have an issue, indeed legacy streamers connected to more than one control point has always returned the error message.

For those with just one legacy streamer and only one control point, posting on this thread, report they get the error message “Another app connected” which prompted my network question.
Do you have any insight as to why there appears to be a second “ghost” control point, when users report the error message while stating they use only one control point?

most likely some sort of caching matter in the Naim software/client OS

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.