NDX 2 Wi Fi not working

Tried today to connect my NDX 2 via Wi Fi and for my surprise the Wi-Fi does not work,it does not find any network, simply does not work.

Also trying to reset with the menu settings the unit crashes.

Could this be that the last firmware update did not go well and broke something?

Is there a way to manually upgrade the NDX 2 to the latest software with a computer?

Thanks for your help.

Daft question, but I’m assuming you’ve got the Wi-Fi antennas connected ?

Yes, with no antenas makes no sense.

Just checking. I’d power it off and unplug it from the mains. Leave it for a few minutes then plug it back in and start again.

I will unplug it 30 minutes and give feedback.

Did not resolve, and Bluetooth is working. I will send it to repair.

Is the wired (UTP-cable) still connected? If it is, remove it, otherwise you can’t connect by wifi.

No I disconnected the wired Ethernet cable.

1 Like

Same wifi network?
Does your smartphone does have wifi connection?
Appears it in the naim app, but no connection to the music? So you can’t hear anything?

Pull out the mains (230V) for 1 minute. Then put it back. The NDX2 will start up. Then (maybe) it wil work again.

Does you have a firmware update?

I have two other streamers here, and they are working with and without cable. The router is close even if my internet speed now is slow on the iPad now, but is sufficient for audio.

Could be a damaged Wi-Fi card on the NDX, stupid I never tried this before.

The flash made me notice I have to clean the dust.

Is there a way to reinstall the latest firmware on an NDX 2?

I’d be more concerned about the strain on those cables than I would be wuth dust.


If the ethernet cable is connected, wifi won’t work. The aerials must be vertical and not horizontal. I’d turn the NDX2 off by unplugging it, remove the ethernet, put the aerials vertical, turn it on again and the wifi should work.

As mentioned by Mike above, arrange the leads so they don’t strain the sockets - the ethernet particularly looks as though the cable is twisting the socket, which may break it.

1 Like

Also, besides HH’s points, before you start thinking about trying to reinstall the firmware, which you would need Naim’s help to do, you could try a factory reset. I forget how you do this on the NDX2 but Google will tell you or no doubt someone else will come along with the answer in a moment.

The ethernet was not connected on the photo. I will send the unit to the store and let them view if it needs service.

Yes but, as others have observed, that’s quite a strain on the visible cables.

1 Like

Longer cables will arrive this week, they will arrive in the same day the NDX 2 will go unfortunately.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.