NDX first second of Flac cut off

Hi Everyone

Hoping someone can help. Recently upgraded from a nd5xs to an ndx. I mostly play 24 bit Flacs stored on my iMac and using either Plex or minim media server.

My problem is the first song that plays always has the first millisecond cut off. Some songs with a slow start or a big gap to start it doesn’t matter. But other songs that start quick you notice the start being clipped off. I thought going to the NDX might cure it but alas.

One thing I have noticed if you don’t listen to the song in isolation i.e listen to it as part of all the album tracks it doesn’t do it. Only if does it if it’s picked out and made part of a queued list to be played. But not if it’s the first song on the album. Then it still does it.

Even if I play a full album of anything the first song is always a mini bit clipped at the start. Fine after that.

If I do mix of all different songs some do it and some don’t.

Have tried listening to a few off the offending files straight on the imac cold with no NDX and they play the start fine. So isn’t the source files.

Help ?! Any ideas ?!



Does this happen only when you switch rate eg from 16/44 to 24/96 and vice versa?
Is it every album affected?

There’s a setting in jriver that allows for this, you can deliberately add a pause of any duration to fix loss of start of tracks

Thanks for the response. Yes every album affected and does it regardless of the bit rate. Some appear worse than it is depending on how quickly the song starts.

I wish that Jriver setting was in plex but can’t see it anywhere. Does anyone know of a decent free media server that lets you tweak this setting ?

Is it safe to say it’s the media server doing this?


Have you tried playing direct from a USB stick

Does sound iMac related. Can you temporarily try a different server platform, or even a NAS.
Are you using Ethernet or wifi?

I have NDX (2014) use QNAP NAS with Asset never had an issue with any file type

The NDX and iMac are both wired Ethernet. I’ll try some experiments with different servers and a known offending track on USB and will report back.

I suspect Simon has it, it’s iMac related.
I have NDX with Synology NAS running Asset UPnP & this delay is not a problem

You can try out jriver for Mac just to see if that setting works, assuming you don’t find another solution. I think you get a month before you would have to register.

Have been experimenting this morning this is what I have discovered:

  • Issue occurs with Plex

  • Issue occurs with Minim server

  • Issue occurs with Emby server

This makes me reasonably confident it’s not media server related. Also:

  • Playing file straight on iMac with VLC on inbuilt iMac speakers no issue at all!

  • Putting said file on USB and playing it on NDX issue occurs !!!

What could that mean it’s the NDX ?! I’m getting confused as to what’s going on or going slightly mad. Extra info:

  • If the offending song is played as part of the album it doesn’t do it.

  • If I clear the queue on the Naim app, refresh the server it won’t do it! But if it’s just added onto songs that have been played before it will do it.

Does that clarify anything or make it worse ?! :woozy_face:

I also noticed this glitch on my new NDX2 when listening to a USB stick.

If I understand correctly, you still haven’t played from a different media server on a different platform via UPnP… as I said sounds iMac related…

I’ve tried different media servers but all via the same platform the iMac. I don’t really have an alternative platform I could try it unfortunately.

Surely though that it also does it independently of the iMac on the USB is suggesting it might be NDX related ?!

If you search www you will find this is a common question across so many audio related brands, Apple, (iMac) HP, Realtec, Roon, Raspberry etc & a whole world of different streamers & streaming applications.
Not many solutions but it seems the delay is the various parts getting synchronised.
If this is an issue, I don’t see this as a bug in NDX as such

Yes I missed that.
Try different media that you have downloaded as well as ripped… and if it happens on all, then it does start to point to your NDX… and if so best contact Naim support.

I too, had similar issues with my NDX when I was using Ethernet-over-mains.
WhenI bought a BT Mesh wifi, the problem went away.
FWIW, I use the NAIM app (Android) and source from Unitiserve and Synology NAS drives.

Ok, so called Ethernet over mains (and it isn’t, it’s typically more a half duplex bridge ) really can’t be recommended. The Naim streamers require Ethernet or wifi to function reliably correctly.

Yeah I’m starting to head that way and resolve myself to it. Mostly noticeable when making a mix of songs, so will stick to full albums for a bit not to wind myself up.

Thanks everyone for their help. :grinning:

I have a few other small niggles I’d like to iron out but will raise that as a separate thread.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.