NDX & M Connect - Qobuz issue

I have the free M Connect app and it worked fine playing Qobuz through my NDX for a month or so. Now it asks me to sign in to Qobuz on M Connect and then just hangs / fails to login. I have deleted the App but has made no difference. Qobuz account is fine and working. Anyone experienced this / got any suggestions on how to resolve?
I also used my son’s Android device to download Bubble UPnP which did login to Qobuz and seemed to allow connection to NDX but then no sound came out from NDX even though volume appeared fine. User interface seemed very poor & unclear so potentially I was doing something wrong. Any advice on this appreciated.
Finally does anyone have another App option to get Qobuz back on my NDX?

You could try the JPlay app on the iPhone.

I tried Jplay on IPad Pro 2018. Lot of bugs. Mconnect worked better, but froze quite often. I use a fiber box and my bandwidth is high.
Today I stream only locally, but if I wanted to stream Qobuz with my Nds, I would choose Mconnect instead.
@AndrewP , try to restart your router, wait, then restart your Ndx.

I have been testing JPlay, zero issues.

1 Like

bubblesoft with the Linn app worked without a hitch for me for years. Hires Qobuz sounded great too.

That’s not an app.

I use Bubble UPNP with my NDS without problems. I choose to control the volume via the 552 rather than the app. There are settings within the app that allow this to be switched somewhere but you would need to check their website for more details

What’s not an app? Bubblesoft or Linn? Both are called apps.

The solution is not an app, read the original post.

I did, another app option is to use the Linn app. McConnect never worked that great for me and the Linn app with bubblesoft worked great once it was set up.

It is now working. I actually got a new router as the old one was giving a few issues. I also signed out of Qobuz on 1 of my other devices (apparently you can only have 3 active)