NDX streamer networking

I have an NDX streamer (have had for some time). In the middle of some fairly extensive changes to the house (insulation, solar panels, heat pump) and so dismantled the HiFi system. Now I’m trying to put it back. All OK except the NDX. The screen on this is not working (hasn’t dome for some time), which normally isn’t a problem - I had sent the NDX to Naim for a service, all working then, but a month or so later the screen died. Didn’t take it back, like an idiot, but x weeks without it was a big ask.
So I have plugged the ethernet cable in, connected that to a network switch (Cisco) and turned on. My Naim app can’t discover the box.
There is another change - I have replaced my BT WholeHome Mesh wifi with a TP-Link Deco one (much better - so much better). I am pretty sure the NDX wasn’t connecting via wifi, so that shouldn’t matter, I think.
So the question is - how can I check/set up the ethernet connection without the screen? Is it possible?

If you plug in an Ethernet cable into the NDX then it should disable the WiFi and just work. But if you have fixed the NDX’s IP address then you may have a major problem if your router has changed because it’s quite possible or even likely that the fixed IP is not in the IP range of the new router. This is an example of why many networking experts would tell you to use DHCP, which is Naim’s default, and not fix the IP address (although there is the option of telling the DHCP in the router to issue a fixed IP which is different).

You say you have replaced the WiFi mesh. So are you sure you have disabled any new router in the mesh setup? If not then your NDX may be trying to talk to your old router, but your phone may be talking to the new router in the mesh network. Ultimately when a phone can’t see a functioning streamer, it’s often because they aren’t actually on the same network.

If your NDX supports 192/24 playback then Naim will likely fit a new screen for under £200 and I think it would be sensible to get that done while you still can. If your NDX doesn’t support 192/24 then Naim can’t fit a new screen because they need the processor on the 192/24 board to do the necessary software support and they have no further availability of 192/24 boards. Then you have a choice of doing without the screen, getting a grey market screen off eBay and fitting it yourself (or getting some other competent person to do it) or selling the NDX for parts.

I meant to add that in terms of fault finding, you could look in your router setup and see whether it sees the NDX or not (ie it has given it an ip address).

Thanks, David - all good suggestions which I will explore.
I’m fairly certain that the WiFi mesh change shouldn’t matter - it was not using wifi before (always had a network cable plugged in and active, and I can see some sort of activity on the lights associated with the ethernet socket - yellow light plus flashing green light).
Looking at my connected clients on the network, there are two unknowns and one identified as 0011F6ACE97E - and I don’t know what that is yet. The others I recognise, though not sure which, if any, is the Cisco switch or my other switch.
I will explore - and yes, I must get the screen fixed. Will do that ASAP.

You can see this on your PC File Explorer (or Mac EQ)
The NDX shows in ‘Network’ click on that and it opens a Naim screen, open ‘Screen Profiles’ and it shows MAC address and other network stuff
My NDX MAC also begins 0011F6, so any bets???

A factory reset would restore DHCP settings and as long as you are happy to use wired Ethernet it might get you up and running.
Turn the power off, then press and hold the stop button, turn it back on, and wait at least 10 seconds before releasing the button.
Then press the play button. After a minute or two it should start up.

1 Like

On a dead NDX screen, your eye cannot see anything but in a truly pitch black room, your phone camera can actually make out a ghost image on the screen. This is how I navigate my dead screen NDX and UQ2.

Discovered this when one of my kids learned at school that a phone camera can see infra red from a remote control which turned out to be true so I wondered if it could see a dead NDX screen. It could.


Interesting. I shall give it a go. thanks.

Tried that - nothing, I’m afraid.

I have tried doing that. Interestingly, on my (Windows) Network screen I can see the NDX, and it has a valid IP address, which I can ping successfully.
But my Naim app on my Android can’t find it. The Cisco switch is connect via a TP-Link powerline thing (which has been working perfectly so far, and is currently linking between my Squeezebox Touch and the PC that has the music on it), so the network all looks OK as far as the Ethernet is concerned.
That leaves the connection between the Android and the network, which is via the new mesh setup, rather than the old BT Wholehome thing. I have tried the Network Scan from the Naim app. Looks like there might be a problem there - my network is 192.168.1.xxx. The network scan shows three devices - two unknown, and one Customer’s Phone, and they are 192.168.68.xxx - no idea why 68 instead of 1, how I force the phone to be 192.168.1.xxx

The 68 instead of a 1 is set by the router not the phone and it looks like it’s just as I said earlier. You have two routers running on your network and so your phone and the NDX are logically on separate networks. You need to disable the router running in your mesh.

Yes, I think you are right. I turned on one of the BT Wholehome units, connect my phone’s wifi to that, and I could see the NDX again.
I will talk to TP-Link to see what I can do about it.

Powerline adapters are notorious for causing connection problems, so my first thought is that you should disconnect this and run an Ethernet cable instead, at least temporarily to see if it resolves the issue.

If, as David says, you have two DHCP servers running, that could also cause discovery problems, in which case you should disable one of them.

I don’t think that I can do that, in practice. It is a long distance (over 20 metres direct line of sight), and no easy route for the wire.
Not sure that would help my problem, though. It looks like the TP-Link is running its own DCHP server, which is a pain. I don’t know how to disable that ATM.

You should be able to log into either the TPlink thing of the router and find the DHCP settings.
Better still perhaps would be to get a decent mesh WiFi setup instead. If necessary put one near enough to the streamer to connect it with a patch cable.

I don’t think there is anything particularly poor about the TP-Link mesh thing - certainly it works better than the BT Wholehome, and gets a good write-up.
But I have solved it, I think. I got onto the TP-Link system and turned off the DHCP part of it - so it is now simply a network extender. Everything has now returned to 192.168.1.xxx and so far seems to be OK - not checked everything out yet, though.
It warns me that it means that things like parental lock etc. are disabled, but my parents are both dead now, so I don’t need a lock for them. Or any of the other features it has when it runs a DHCP router.
So far, so good.
Thanks everyone for their help and suggestions - very helpful.
Still need to get the NDX back to Naim for a new screen or repair. Darn it.

I agree the BT Wholehome was a 2nd div system, but please don’t confuse BT’s “Wholehome” with BT “Complete Wi-Fi”

I added the Wholehome extender disc (the white disc) with the 1st generation Smart Hub. And yes, it left a bit to be desired, I can only think it was a first attempt by BT with extenders.

I now have BT Smart Hub-2 “Complete Wi-Fi” that includes black extender discs that are designed exclusivly to partner with Smart Hub-2.
All I can say is its been faultless, OK the Smart Hub-2 does not have the ability to fiddle around with some settings as the 3rd party routers do, but its purposely designed that way to be tamper (fool) proof and in that regard BT have it just about right, it works first time straigh out of the box.

I understood from your earlier post that the TPlink stuff you had was “powerline” which is why I suggested you removed it. If it’s a mesh setup it should be fine, and hopefully with just one DHCP server running you’ll be fine.

Ah - both are true. I used a TP-Link wifi over mains to get the basic connection between my router at one end of the house and the hifi and Cisco switch at the other end. And the TP-Link mesh for general WiFi connections.
I have now removed the ethernet-over-mains bit at the Cisco end, and everything seems to be OK (having switched off the TP-Link’s DHCP) and am looking a the other two EoM devices to see whether I can remove them, too.
The EP-Link mesh seems to be very good - plugged in and it worked.