NDX XS 2 Spotify issues after upgrade to 3.5.1

hi all, I hope I can find help here. I just Upgraded my XS 2 to the 3.5.1 firmware, and now there’s silence. The situation so far is:

  • After upgrading Spotify became unusable: 10-25 sec delay between actions on the smartphone and reactions in the player, often double playing (phone & naim), constant abortions of the stream
  • power off / on did not help, reboot of mobile device did not help
  • reset of naim using the reset switch
  • Error connecting to the wifi (according to app), yet device connected (green LED)
  • App finds the device, but get’s stuck “looking for new firmware”.
  • Multiple app kill/restarts later I can configure the device

The situation NOW is:

  • any action on spotify takes 10-30 seconds to be executed on the naim (switch song, wait 30 seconds
  • selecting playback on the XS 2 from the spotify app are a one in ten (nine times it just aborts).
    • selecting “continue playback” in the naim app usually works - after a while.
  • I get double plays (phone & naim)
  • songs jump forth and back during the first minute, then playback stabilizes

basically, it’s unusable.

can anybody help? any help appreciated!

cheers,
axel.

Update: Webradio does work nicely, Chromecast (from Spotify) doesn’t work at all. At the moment no Spotify playback at all possible.

@the-me Is your streamer connected by ethernet or wifi? I my unitilite streamer connected by wifi but it would randomly drop out and Spotify was not working well. Switching over to ethernet solved all issues.

@TO_Vinyl good question - it’s wifi. but the connection always worked flawlessly. also the web radio works just fine without issues right now.

i briefly thoght about re-flashing the firmware, but i was unable to find it and the mac os updater requires an usb-serial converter. which i havent seen in a WHILE :wink:

You don’t upgrade the firmware that way on the ND5 XS2! It’s an “over the air” update. The ND5 XS was different.

You should contact Naim support and let them help you to get it sorted out.

Best

David

just sent the email. so no music this weekend for me :cry: . this is so annoying.

I suspect that you haven’t actually managed to reset the unit to factory settings. It should be like it came out of the box, so you would have to setup WiFi again for example. I would try resetting it again, ensuring that you hold the reset button in for long enough. The instructions say at least 10 secs and until the network light goes orange. Is that what you did?

Also log out of Spotify in the Naim app and then login to Spotify again.
Best

David

@davidhendon I did have to re-configure wifi. 2nd reset … why not. I’ll try. can’t make it worse really :slight_smile:

Ok. I will await further feedback!

Best

David

I held the reset button REALLY long (about 30 sec), and after restart the LED has turned blue for about 10 minutes. :confused: . I just plugged in an ethernet cable in case it tries to download the firmware and can’t because of a missing wifi config. I don’t really dare to switch it off.

UPDATE: but strangely the web interface is reachable, and it says firmware is up to date.

i am becoming really unimpressed by this software. this feels incredibly fragile.

Update. after 20+ minutes the LED changed to orange, then orange blinking, now it’s green.

Several app resets later (this gets old as well) I can again play back - if I wait 30-40 secs until the XS 2 reacts after several attempts to “continue playback” from the naim app. spotify gets horribly confused if I try this (btw no difference between laptop and smartphone).

switching songs has improved - it’s now only about 15-25 secs delay.

Did you try logging out of Spotify and then log in again?

Also now it’s working, can you use ethernet instead of WiFi?

Best

David

I am using ethernet, and I wouldn’t call this “working”. try to play back a song for about 5 minutes now, not working at all.

and I logged out of spotify several times. I’ll try again.

logged out, logged back in, same result. 30 secs delay and unusably fragile. now songs start over randomly.

I’ll leave it at that, this is just too frustrating. web radio it is, spotify is just utterly broken beyond repair here. hopefully support can help me monday.

but many thanks @davidhendon and @TO_Vinyl for offering your suggestions!!

You may find you need to phone Naim support because they are very busy and email replies can be very delayed apparently. Also a conversation can get far more information across quickly.

Maybe it’s a local Spotify issue (I see you aren’t living in UK). You could try an email to Spotify support too, telling them where you are located.

Best

David

cool. I was out drinking wine with friends and let the system running by accident. now it works.
there is wisdom in wine it seems … :laughing: . very annoying, but finally fixed it seems. if it keeps working i won’t complain.

Glad it’s working. I haven’t seen anyone else commenting on a Spotify issue like your’s with this firmware, and I include in that during the beta testing, nor were there reports yesterday on the forum of a general Spotify issue, so hopefully it was a Spotify server problem for your geography in particular. Time will tell no doubt.

Best

David