NDX2 and Muso network problem

NDX2 & Muso connection problem

I have a network problem which I wonder if anyone can help me with please.

I have had a muso (first gen) for several years and used it quite happily in standalone and multi room mode with my NDX. The NDX is a wired connection and the muso is wireless as it gets moved around.

I upgraded to an NDX2 a few weeks ago and since then I have had problems with the muso. Every 6 seconds or so the music hesitates or stops for a very short moment and then carries on. I tried the muso in several rooms and it is the same, this is using it in multi room mode from the NDX2. Using it in standalone mode it works fine, whether playing from my NAS drive, Spotify or internet radio.

I tried the usual things, rebooting the NDX2, the NAS drive, the router (Netgear Nighthawk X4) and even the ipad, but to no avail.

I contacted Naim support and they suggested that I try connecting the muso on a wired connection and see if it still happened, which is when things got rather worse.

I plugged in the muso using a cat 6 cable to the Netgear switch, but then the NDX2 disappeared from the Naim app, so I have been unable to try the muso in multi room mode yet

Unfortunately, ever since then I have been unable to get the NDX2 to connect to the Naim app, despite rebooting everything in the chain several times. Naim now suggest that I take it to my dealer to try it there, but my Naim dealer is an hours drive away and being over 70 I am supposed to stay at home due to the virus issues, so if anyone has any suggestions, this would help me.

Luckily I still have a large quantity of CDs packed away in boxes so I am playing these in my DVD player for the time being, that helps me to stay sane!


A few tips to try. While I read you have tried a power cycle the order you power things back up is important.
Turn your Netgear switch/router off at the wall. Do the same for the Mu-so and the NDX2 and NAS drive.
Turn the switch/router back on. When the switch is back up and only when, delete the Naim app from your device and then turn the Naim boxes and NAS back on. Wait until they are all powered back up. Reload the Naim app, find rooms again and report how you go.

Many thanks for the reply, I hadn’t realised that the order was important here. I will try this later on and let you know how I get on.

It sounds like the app isn’t refreshing its understanding of the ip addresses where your rooms exist. Restarting everything in the right order should resolve that.

But something you may not know is that if you are in the Rooms page of the Naim app, and you pull down the page and release it, in the same way you pull down and release the email list in the Apple email app, then the Naim app will refresh its internal list of Rooms and their opening addresses. This often means a vanished room can be found in a couple of seconds.



Thanks again, I have just tried following your instructions very carefully, but sadly, it still doesn’t find the NDX2. I also tried setting up a new product, but finds nothing either.

Thank you David, I did know that, but I appreciate your telling me.
Sadly I tried the reset procedure but it still couldn’t find the NDX2

Stumped. Other than try it all again, all hard wired. No joy then time to chat to your dealer. Let us know how you get on.

Thanks for your help. I am about to speak to my dealer and will let you know.

Sorry I’ve only just remembered this thread. Did you try setting your NDX2 back to factory settings? Apologies if you said already about that but I missed it.



[quote=“davidhendon, post:9, topic:7187, full:true”]
Sorry I’ve only just remembered this thread. Did you try setting your NDX2 back to factory settings? Apologies if you said already about that but I missed it.



Thank you David. I hadn’t tried that and normally I would try that now, however I have found a workaround by using the Qobuz app on the iPad and connecting via Bluetooth to the NDX2. That way I can play music very well.
I am reluctant to try a reset in case it takes it back to the original software which does not have Qobuz. I would have returned it to my dealer to check out, but they are now closed due to the Coronavirus. So best to mess with it until things ease.

My guess is that this is a network setup issue that the streamer doesn’t like, rather than a problem with the streamer per se.
Good that you have a workaround solution for now. I would have thought you might get better results using Airplay or Chromecast from the Qobuz app rather than Bluetooth.

The factory reset won’t take your firmware back to an earlier version. That isn’t the way it works. But I can understand why you would stick with the workaround until things are more normal.

I agree with Chris that it’s probably a network issue, but the way that the problem came about as described in your first post does makes me wonder whether something has got messed up in an obscure function in your streamer. Hence the factory settings suggestion.



A factory reset would be my suggestion too. I would disconnect the streamer from the network and restart the router at the same time, and see if the router will see the streamer as a new device to be assigned an IP address when it comes back up.

Thanks, I will give this a try and let you know

Thanks, I will give this a try

Just read this… I didn’t see unless I have missed it that you have confirmed all your devices are set to DHCP to obtain their network parameters from your router.
If you confirm this, can you share the details the router assigns the Muso and NDX2 … it will be on your router control/admin web page.

Confirm both are set to DHCP, then power cycle off everything… leave it off for 5 mins… and then confirm the router is assigning details to both devices when you power them on again, it will help confirm what might be happening.

The good news is the NDX2 and Muso/Qb are quite happy residing on the same network, as that is what I do here…

Hello Simon, thank you for replying, sorry to take so long to respond, I have been rather busy with other things recently.
I have looked in the router admin and confirmed that it is set to DHCP and a screengrab of the settings is below. The mu-so has the IP address ending in 1.7
I have also turned off the router and left it for 5 mins.
The NDX2 cannot connect to the internet at present so is not listed. It also cannot connect via the wired connection to the NAS as if I try to play it from the control panel/remote nothing shows up.
It would be good to take it to my dealer and try it there, but that is impossible at the moment. In the short time I am not too concerned with the mu-so issue as it works perfectly well as standalone, but it would be good to get the NDX2 working again. At present I am using the Qobuz app and sending it via Bluetooth. Thanks for your help.
If I use the reset on the NDX2, will that leave the updated software still intact? I haven’t tried that yet.

Yes your NDX2 upgrades will remain intact if you power cycle /reset the NDX… so if connected via Ethernet and you power cycle and it fails to appear in the DHCP list… that points to either the Ethernet lead or the NDX2 being suspect (ensure NDX2 is set to dhcp)

Thanks again. I have reset the NDX2 and then powered it on and off. I have also changed the network cable. I have also swopped the socket in the router to one I was using for something else. In the setup it recognises the wired input.
Still not able to connect to the iPad or to connect to the NAS when using the remote.
So I guess it looks as though it is the NDX2 which is at fault.

Thanks everyone for your suggestions, I will contact my dealer when we eventually get back to more normal times.

1 Like

@Martin Just looking at your earlier posting of your router permissions, you haven’t got access control enabled at present. I wonder whether if you ticked the enable access control box and left the rule as allow all new devices to connect, that might flush out allowing your NDX2 to connect.

I suggest changing those settings and then restarting your router. Obviously restart the NDX2 and the Muso too, after the router has fully restarted.

It wouldn’t take long to try and I’m still remembering that it worked until you tried to allow a wired connection (your first post). I still think this is probably a network issue and it would be a shame to wait several weeks/months for your dealer to look at it and discover you could have fixed it now!