NDX2 - doesn't display server as an input

Hi,
Have loved my NFX2 for 18mo. This morning I am unable to stream music !!

The NDX2 does not show “Servers” as an input on the display. I can select a server on the app and choose an album but it of course won’t play.

The NDX2 is wired to my network and has a flashing ethernet connection. If I login to the network from a PC I can see the NDX2 and it has a valid IP address using DHCP. Music is on a NAS DS220+ running Minimserver (it is running OK).

I’m at a bit of a loss, so any suggestions would be appreciated !

Robert

I’ll say the obvious one (it works with my NDS when this happens)… Turn it off and turn it on again

The NDX2 never shows servers on the front panel display, as far as I recall. If you can see it on the App but music won’t play, it’s worth rebooting the NDX2 and if that doesn’t work, rebooting the router, NAS and NDX2 in that order.

I think it does, I renamed mine as Zen Mini on the input settings, fairly sure the original factory setting was ‘Servers’, OP might want to check it’s enabled in settings / inputs

HH is correct, 2nd gen streamers cannot access the Server input (or Tidal and Qobuz) via the front panel display and remote control. You have to use the app.
Unfortunately that doesn’t solve the OPs problem.

Thanks for your suggestions so far ! I have tried the “Turn it off and on again” process with NDX2, Router, NAS, all to no avail. All software is updated.

I was pretty sure “Servers” does appear as an input device on the NDX2, as it does on the app, but happy to accept I’m wrong! On the otherhand, as far as I recall, if you select music on the NAIM app the NDX will autodetect the input and will play without any further intervention. Either way it’s not happening !

As I say, I can connect to the NDX2 from my PC, so it’s definitely on the network. Minimserver is running on the NAS server. The NAIM app is connecting to the server. So it’s a bit of a mystery !
Robert

Is iRadio working on the NDX2? If it is, it shows the NDX2 is connected properly. One thing to try is to turn Minim off and then restart it.

Have you tried killing the app by swiping off the screen, then restarting it? Presumably the answer is yes.

Presumably you have logged into your Synology and can see that Minimserver is running properly on it? If, so, perhaps you could try enabling the bundled Synology server and see if that is discovered in the Naim app; or any other server.

Thank you all for taking an interest. I installed the Naim App on my i-phone and it then it worked !! I’m not sure where the fault lay. I went back to the ipad intending to reinstall the app but found it was now working OK on the ipad as well. So it remains a bit of a mystery.
As I say, thanks for your help, a mystery resolved if not solved !
Robert

1 Like

ah ok, I misread re the front display

Resurrecting this thread - I found this out to my frustration yesterday on my 333 when my iPhone was doing an update.

Wondered where the ‘Server’ input had gone on the Home Screen…assuming it had always been there.

Checked a few online images and of course it’s not. I wonder why Naim wouldn’t allow access to servers via remote vs the app? Always managed it with the Gen 1 NDX.

Yes, the second gen. streamers don’t allow you to access the Server, Tidal or Qobuz inputs via the remote/front panel display. It does seem a bit odd to have a much improved full colour display and fancy Zigbee remote and limit their usefulness.

1 Like

Always though that was a bizarre decision on Naim’s part. Surely a firmware update could correct this?