Need to switch to another source and back to optical to get sound

Hi all, I have an issue with my Uniti Atom. I am using one of the optical inputs, the sound is coming from my computer, and whether I boot it on MacOS or Windows, the problem is the same.

When I take my uniti atom out of standby mode, I get no sound on the optical input. I need to switch to internet radio (or any other source) and then back to the optical input to make it work.

Things that I have tried:

  • Dual OS, same problem so it can’t be a setting or driver.
  • Tried to swap cables, problem remains
  • Switch the cable to another optical input… same result

I haven’t found much about this on the forums so I might be missing something obvious… If anyone has ideas, please let me know.


How are you connecting your computer to the optical? Via an adaptor?

Ok… two things spring to mind… the Atom is indeed faulty perhaps with its firmware, however to narrow that down, can you try an alternate digital source, even temporarily, as it could be the transport clock on your computer SPDIF feed is on the edge of tolerance.

My first thoughts are as Simon suggests above, that the computer s/pdif output may be poor (they usually are not so good) and so it’s difficult for the Atom to lock on. A good idea to try a different source and see if you get the same issue.

It’s usually much better to use something like an asynchronous USB-s/pdif interface between your computer and DAC where the signal is not dependant upon the clock fro the computer.

Interface, yes, that’s what I meant, not adaptor.

Hi all, and first of all thanks for your time and answers.

I followed your recommendation and plugged a chromecast audio in, and the exact same thing happens. I have to switch to another source and come back to the optical one to get some sound. The optical cable was also different and I tried on the 2 optical inputs to no avail.

Also when I do the - going to another source and back to optical - trick I can unplug the chromecast, plug the PC in and everything works.

I hope it’s a firmware, not a hardware problem… It’s a nifty little unit but I ve had issues alread (blank screen and this)… Do you know which firmware is stable enough to try? also is it possible to downgrade, I’m on the latest software update finds.

Really appreciate your help.


I recommend you get in touch with your dealer or with Naim support and tell them as much about the issue as possible and take it from there.

I agree with Richard… a conversation with your dealer is the next step…

Thanks all. It looks like this has been seen before, @G_Ross mentions the exact same thing in the 3.2 firmware issues post, so I’ll write to support and talk to the local team.


Hi @Tleej,

I still get the same issue on 3.4.0 (4492) but it is only occasional now. Mostly, you can here the ‘click’ when it first turns on… and then sometimes it doesn’t, so have to switch to another source, hear the ‘click’ and then switch to the Optical input I wanted.

Hi @G_Ross and thanks for the follow up. I have tried turning on ‘server’ mode and am getting much better results. I think that the problem comes from the wake up procedure, screwing up for some reason. To be honest, I was expecting a better experience, but it might also be a hardware fault. Have you spoken to support about it? They still haven’t replied to me.


I haven’t tried support. I reverted back to a previous firmware a while ago and it worked perfectly, so I am convinced it is not a hardware issue. I will however, give the ‘server’ mode a try and let you know how I get on…!

I have had the unit in server mode for the last week, and indeed, it has worked faultlessly so far.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.