New Muso Firmware failed to complete

Thanks Clare. I’ll try turning it off for a time. The phone app’s locked up and won’t let me access anything. It just says it can’t find the Muso/room and doesn’t offer any other options.

That is definitely a network issue - please do ensure you restart your router and devices as well as power cycle the Mu-so

Power cycle?

Fully unplug from mains for 15-30 minutes, as mentioned above.

Yes, it’s been unplugged overnight. Just restarted the router, plugged Muso back in. Also restarted the app. LED still blue. Still 3 segments out on Dial, and pushing reset button does nothing. I’ve now left it for an hour, and the LED has turned red and there is only one segment lit on the dial :sob:

I have recently been trying to apply this update, and have just joined this forum. I looked at it a couple of days ago (efore joining) as I was having no luck with the update. I am running the Naim app version 2.22.3 (AFAIK this is the latest version). My phone is on Android v 9. The speaker and phone are on the same network - the speaker is attached to the router via a cable. The WiFi speed is around 60 Mbps (depending on exacty where the phone is in realtion to the router; Broadband wired speed is generally around 110 Mbps. When I check for firmware update, it says installed version is 1.8.0; available version is 2.0.0.

When I tried updating, I am told Mu-so Qb is updating - Downloading firmware file. This stays for 10 minutes or so, then I get a box with the very unhelpful message: Error Update Error.

I have tried all the suggestions I could see on the forum: reset using the pin; totally disconnecting the speaker for a couple of hours. Neither worked - I have tried What I haven’t done is reboot the router.

Please could someone suggest what I might try now.

Also, I don’t use (nor do I plan to use) Tidal - do I really need the update? Are the other changes significant (I have read what has beenimproved/fixed, and I can’t see anything that means a lot to me. However, is it going to make a difference in the future if I miss out on this update?

Given my experience, jrsee, I’d steer well clear right now. I’m locked out of the App, locked out of the Muso, out of guarantee, and dreading what comes next.

We won’t leave anyone behind - our tech support team have extra ways/means they can help people encountering issues and get them up and running.

You can email them at, or call them on 44 (0) 1722 443405

Please reference this Forum thread or any others, so they can see the steps you’ve already taken, and feel free to share your ticket numbers with @Richard.Dane or I for follow-up.

1 Like

Thanks Clare, I will try phoning later this afternoon, or more likely tomorrow.

1 Like

Thank you, Clare. Appreciate it :blush:

1 Like

Just to let you know Clare (and anyone else incl ExiledRoyal still unable to update to the latest version), I contacted Naim help desk (number in Clare’s post above) - very quick to get through - and spoke to Duncan. I explained my particular situation (as per my last but one post on 17th Nov). Duncan sent an update file (via Dropbox), and it worked fine - took about 20 minutes. Thanks for everyaone’s help.


Glad to help, and really happy you’re sorted via those special ways/means the Tech Support team have!

Duncan always comes through!

I sent an email, but it sounds like the phone will be better! This solution’s given me hope! Waiting :blush:

Hi Clare, I have the same issue. It’s powered off for 30+min, plug the power cord back in why holding in the reset, blue LED comes on and every second segment on the dial lights up. It does not go past this point. Appreciate it if I can have emailed the same firmware update.

Nick, I would recommend you contact Naim tech support, as per the others.

p.s. I have removed your email address. Please don’t post personal details on a publicly viewable forum as it’s not safe to do so.

1 Like

Just to say that it’s appeared to have righted itself. The only difference from the other attempts is that I took a music USB stick out of the USB slot. Unplugged it and waited. I then pushed the pinhole in with the LED still blue. A few minutes later the whole thing came to life. No idea why. But all good again! So thank you for the attention that I’ve received. Felt supported!

1 Like

So glad you’re sorted!

If you let me have your ticket number, I can ask the Naim Support team to mark the query as fixed.

1 Like

Hi Clare. It’s #126211. Thanks so much for your input!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.