Newest Firmware Update for ND 555 Failed

I initiated the firmware update released back in july of this year. The white status line would move to the right. I would check after a few minutes and a new status line had begun. This happened 2-3 times. I watched the line quite frequently waiting for it to move all the way to the right. Once it did, nothing happened. The screen on the 555 appears to be frozen. Pressing the off button on the remote does not turn off the the NDS. The Naim app on the iPad Mini allows me to select different sources and I can listen to internet radio and TV. The remote does nothing. Has this happened with anybody else? Because I am not close to a dealer, I hesitate to shutdown the NDS. Any suggestions?


Do you have an ND555 or an NDS.

The software update is for the ND555 and not the NDS.

You should shut down the ND555, by which I mean turn it off or if the front panel switch won’t do that then pull out the mains lead. Wait a minute then plug it in again. It should restart and carry on with the update.

1 Like

A white progress line can only indicate that it’s a new type streamer, so I assume an ND555, although the post is confusing. If so, there is no power button as such on the unit itself, instead this will be on the 555 power supply (or two).

I have done a few updates where it has taken quite a while and appeared to have frozen, which I have attributed to slow broadband, but it has always come up with the Home Screen in the end. If this doesn’t happen within 15 minutes, I’d do as David says, unplug the power supply(ies) from the mains, wait, restore power and see if it recovers.

There is no need to turn anything off at the mains with an ND 555, or an NDX2 when powered by an XPS or 555PS. Just turn off the power supply with the front button, wait about a minute and then turn it on again. The update should restart, or can be initiated again via the app.

My apologies. My previous network player was an NDS. My current streamer is the ND 555. This morning I turned off the power supply to the 555. When the 555 came up, the Standby button on the remote worked. Now I will initiate the update and I am hopeful that this time, the new firmware will be installed.

Hopefully it all works now; useful to update your system on your profile?

Hi David,

My attempt to download the firmware again is responding the same as yesterday. The white status line has moved totally to the right but nothing happens. Do you have experience with turning off the power supply and then waiting an appropriate amount of time before turning on the power supply?

No you don’t need a specific time, just long enough that everything stops. The post from @Clive is quite correct. I had temporarily forgotten that the ND555 doesn’t have an internal power supply.

You could try initiating the update again, but if that doesn’t work then I think calling Naim Support (or your dealer) for advice is probably the way to go.

I loaded the Naim app onto the iPhone and tried to install the newest firmware. Turning off the power supply for at least 30 seconds after the white line was all the way to the right also did not result in the firmware being installed. I have sent an email to Naim and left a message with the person who sold me my system. He will return to work on Wednesday. My speeds are 473 and 119 so I do not think that is a problem. I will check the Naim support page again but I did not recall seeing a number for me to call in the U.S. Thanks for your ideas.

It wouldn’t have done! You misunderstood me.

Normally you turn the ND555 on and either it sees or you trigger a firmware update. You leave it to get on with it and after 10 or 15 minutes it will be finished. You can tell because it reappears in the Rooms screen in the Naim app and there should be the menu screen showing on the ND555 front panel display.

If it’s sits there for half an hour or so and isn’t showing signs of anything happening, that’s when you turn it off for half a minute or so, using the front panel button on your power supply. Then turn it on again and once it has started up, it should have another go at the update or finish off the previous attempt.

1 Like

The North American NAIM distributor is in Canada:

They are extremely helpful. Ask for Michel (ext. 9).

Thanks to all who provided ideas concerning the downloading of the new firmware. Naim Support suggested shutting off the power supply for the ND 555 for 30 minutes so the two units could totally discharge. The download still did not work. I was then able to speak with the person who sells me the Naim products. He had experienced a very similar problem with a Uniti Core. He disconnected the ethernet cable and used WiFi. That worked for him. I disconnected the ethernet cable from the ND 555 and WiFi connected to the unit. As soon as I initiated a download, the process started. The ND 555 now has the newest firmware.


Did u go back to the Ethernet cable after update loaded?
Not sure why it only updated with WiFi?

The UnitiCore doesn’t have WiFi so he misremembered what his other experience was with. However, I have heard before of this happening with a muso Gen 2 so it is apparently a thing!

Anyway I’m glad it worked out ok and it is interesting to know how you solved it.

Yes, I returned immediately back to the ethernet cable. Connon feels that the sound is better plus the connection seems to be more stable with ethernet. Connon also had no idea why WiFi worked for him.

I may have not remembered correctly that Connon had problems with the Uniti Core but just out of curiosity, I will check with him again. He has sold Naim products for over 10 years. He knows the products demonstrates them in the shop. He reminds me of the field service engineers that would arrive in the lab to work on the analyzers. They are out in the field and experience real life problems. I worked over the phone with tech support many times when the analyzers were on the fritz. They are also quite helpful but they are not out in the field working on the medical analyzers. I did send a message to Duncan who works in Naim support to let him know how the situation was solved but have not heard back from him. When our analyzers had problems, or in this case, when my ND 555 had its problem. the advantage of troubleshooting is that I always learn more. Rather a long reply but I am stuck inside for the third day in a row because of hazardous wildfire smoke.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.