No internet radio

Hello everyone,

The new Muso Qb that I own is really confounding me. At first it was DLNA servers, now its internet radio.

There are a few presets for radio which I tried and even after doing a factory reset and making sure my WiFi router is up to date, I still cannot stream any radio station nor can I browse a list of available stations. My Muso is about 1 meter from the router so I don’t think its a signal strength problem. By the way, my routers are Netgear Orbis with 2 satellites and I connect multiple devices all over the house and there has never been a problem.

With all preset channels, the status is nearly always “Connecting”. Occasionally, I notice it says to “Reconnect” which changes to “Connecting” when I tap on it.

The Muso is able to find all my DLNA servers and plays without any problem.

The factory resets did not help at all.

Any suggestions would be welcome before I report this to Naim.


My internet radio on muso 2 and QB2 not working either. Been troubleshooting for hours.

Glad I’m not the only one. Don’t mean to be uncaring. Just means there’s an issue with the product!!!


Another mystery to solve. I turned off my DLNA server and internet radio streaming works now. What the …???

Coincidence perhaps… my internet radio just started working… no changes to anything… hadn’t worked for hours… bizarre!

Ok. Now that I believe it was my DLNA server that caused the glitch, I am able to receive radio. However, I’m trying to add more stations using and it does not work.

I will create a new thread for this.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.