No Radio Stations showing under IRadio

I have no stations displaying under IRadio for my Muso Gen 1. Working fine for Atom and Nova.
I have radio stations under presets which do work but load very slowly for Muso.
I have radio stations set with Minimserver which do not work with the Naim app for any any of the three players. Work fine across all three players with BubbleUPNP as the control point.
I have reset the Muso a few times. While I am getting help from Naim support does anyone have any ideas?

So far Support have asked me to run a wireless network check and that has come back telling me it is very good. Man how bad are these reviews for Naim’s support: Naim Audio Reviews | Read Customer Service Reviews of

Try deleting the Naim App from your phone/tablet, reboot the device (power off then on) and re-install the Naim App. I have a first Generation Qb and have no issue. P.S. do you use Apple or Android?

If you are using the Muso Gen 1 with a WiFi connection, then that is probably your issue. You could try connecting it to your router with an Ethernet cable and restart the muso. If that doesn’t work then restart the router and when it has finished restarting, restart the muso again (by restart I mean power off completely not just switch it off and on again.)

If that doesn’t work then you should try a factory reset of the muso.



Thanks both,

I have tried all steps including factory reset to no effect. I have tried with both WiFi and ethernet.

I have tried with both the Apple App and Android - no joy.

I do not think there is very much else I can try unless anyone had any further ideas. If Naim support comes up with anything I will post up to here.

Did this muso use to work on iradio and now doesn’t or is it newly acquired?

Hi David,

Used to and now does not. Did not seem to coincide with any changes, working one evening and not the next morning.



It’s odd. I’m allowing my mind to freewheel to see if anything else to try occurs to me….

Yes any thoughts welcome. I am out of ideas for the moment.


Have you tried turning off both the router and the muso? Then let the router fully boot up and then turn the muso on again.


Been there HH….

This is a little confusing. You have no radio stations but still you have one or more presets assigned to a radiostation. Did that work in the past? Since I believe all faovrits are wiped out by a hard reset I wonder how you can get the presets to work?


Yes the presets worked in the past and still work now but take over a minute to actually start streaming. IRadio was working but is not at all now.
Yes it is odd. I have carried out a hard reset as per: Mu-so Support | Naim Audio
I thought this would remove the presets but they persist. Perhaps my Muso has a few issues.
I am not at home at moment but will follow the advice re router reboot etc tomorrow and have another go at reset.

It’s restore factory settings you want, not hard reset. The link you included has it a few lines down.



Sorry might be my language was too loose or link wrong: this is what I followed, As I say I will perform all the steps again tomorrow. I am trying to travel hopefully…



I have carried out all the reset and turning off suggestions to no effect.
I do not think the Muso is actually resetting - it goes through the steps and shows flashing purple but the presets are remaining in place.


Update: Naim support have been pretty good but I think we are coming to the end of the road. I have tried super hard reset, with the warnings over bricking the Muso ringing in my ears.
It worked ok in that the Muso sprung back to life but the iradio is still non existent.
If I select it then no stations I get nothing but a black screen. After a few minutes the last radio station played from the presets starts playing.
I have had a spin with Roon and quite liked it but that get complaining that others were accessing my core so I have dropped that. Sharing it with family.
Bubble UPNP with Minimserver is what I am sticking with - gives my Qobuz with the Muso.
Now to get back to simply listening again
I sometimes think I should have stayed with vinyl. :slight_smile:

Have you tried taking the muso to a differnet house and just plugging it in. Would rule out anything strange iin your whole network/streaming setup if it by chance would solve the problem.

1 Like

Hi Claus. Thanks good idea - I will do so and see what happens.

Update: tried it at local dealer (seemed best plan) and it is just the same. Unless Naim or someoen on here comes up with something I am at the end of the road with this.