Odd Asset/Naim App/Naim streamer track skipping issue

I use Asset 6.1, on QNAP 251 which feeds a Uniti Nova. I use the Naim IOS app on a variety of IOS devices.

I have an odd, but very intermittent issue where the Nova will play track one of an album selected through the Naim app; it then, rather than playing track 2 will jump to a random track. It will then continue playing the album from that point.

If I restart the album it will move from track 1 to 2 normally.
If I select track 2, after it’s incorrectly jumped, it will then play the album correctly.

It only seems to happen on the transition from track 1. Random play and repeat play are OFF.

This is very infrequent and once it happens it generally doesn’t happen again, so any action I take can’t be shown to have made a difference (such as clearing cache, resetting app).

All metadata is correct (created with dbPoweramp and checked with that and Perfect Tunes - both on Windows). The file name starts with the track number and all tracks are of the format 01/10, 02/10, etc. Just becasue an album does this once doesn’t mean the same album will neccessarily do it again (though The Dark Side of the Moon has done it more than once). Albums can be gapess or not, so it’s not that.

NAS is connected to Cisco 2960G switch, as is the Nova. Router doesn’t seem to make a difference as this has happened with more than one, but currently TP-Link 2800. Reserved DHCP addresses are used for the switch, Nova and NAS so it shouldn’t be a routing issue.

Anyone seen this or have any ideas ?

(I can take Wireshark traces, but don’t know what I’d be looking for - I have port spanning enabled on the switch for the Nova’s port. Having said that this isn’t feasible as I can’t predict when it’ll ‘fail’ and I can’t run a “forever” trace.)

Sorry, not seen this. Sounds like a horrible one to figure out!

That IS an odd one, and to diagnose at this point I’d use a different media server on your nas and see if it keeps happening. Asset is my first choice as well, but you need to narrow it down to see if it’s happening within your Nova or outside of it.

I had the same a while back, I fixed it very quickly & TBH it was so that I don’t remember what I did …
Have you tried clearing both app cache’s, deleted the app, power cycled the iPad & reinstalled the app

Bart, I’ll do that, I’d never really thought it was Asset, so that’s a new direction.

Mike-B. Generally this goes weeks, or months, between occurrences so I’ll never know if I fixed it or not ! Yes, I’ve cleared caches, app data and removed/reinstalled app, reindexed Asset, rewritten metadata, anything I could think of - but as it never repeats it’s going to be a long one unless someone else says “oh yes, had that, fixed it”.

Thanks both though, I’ll go through all that lot again and try another server

We don’t know if it is or isn’t, but it would be a shame to return the Nova for replacement or (unneeded) repair if it’s the server! And you’d still have the issue . . .

Ah, a bit of info I missed - I’m on my second Nova - the first went back to Naim for investigation (for different issues), and they offered to let me keep the loan device (which was brand new). The original also showed the issue so it’s not the Nova (unless it’s a firmware issue).

I’ve also changed routers and switches since I first had this happen so it’s unlikely to be those. I do update the QNAP so if it’s an issue on that they haven’t spotted it yet.

I had thought it only happened on gapless albums, but it happened on the Bowie remaster/remix of Station to Station at the weekend - I don’t remember that being gapless (the 2010 remix, not the original album remastered. From the boxset)

I have had this happen on an Atom / Synology / minimserver a couple of times. Didnt take much notice of it, just put it down to ‘one of those things’ . I vaguely seem to remember that it was dependent on which screen of the IOS Naim app I was on but didnt investigate any further.
If it happens again I will take more notice and report back.

I have been having this problem since I got my Nova.

At first it only happened once in a while, but about the beginning of last December it got a lot worse, it started happening nearly every day. It also happens occasionally with Qobuz Studio and with Tidal HiFi.

I contacted my Naim dealer and they have had several other owners hoo have suddenly started getting this problem.

My dealer contacted Naim support after the winter break and are still waiting for a solution to this problem.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.