Odd behaviour with Asset Jukebox Track Selection

I’m experiencing some odd behaviour when selecting the Jukebox Track Selection option under Asset (on my 3.7v Atom using the latest version iOS app).
If I ‘click’ through I can see a whole load of tracks in the selection, but when I select Play, it only loads 5 tracks into the play queue.
It’s doing the same thing on my ND555 using the slightly earlier version of the app on my iPad.
My 1st Gen QB is a little more successful - it loads 100 tracks - but still less than the 500 I expected.

Can anyone else replicate this? Any thoughts?

I don’t use Jukebox so can’t really help. But have you had a look at the Asset section on the dBpoweramp forum, there are a few Jukebox issues reported.
It might be worth asking them for help on our problem.

Could you give it a go @Mike-B? Just to see what gets loaded into the play queue? (Unless you don’t have it in your browse tree, of course.)
I can’t see anything specific to Jukebox issues at the forum.

Hi @GavinB … I away from home until next week so can’t try it until Monday pm
Apart from that I don’t have Jukebox in my browse tree, never used it in fact, however I can easily give it a go next week.

1 Like

I use Jukebox most of the time. If you hold/press on the jukebox track selection rather than opening it, it will ask you to press play. This then selects 500 tracks (limit on my Lite). Occassionally it’ll only load 95, but this is because my QNAP is waking up.

Also make sure asset has the relevant setting altered I think 1600 is the max.

I also use M-Connect and in that app you have to go into the jukebox track selection folder and just play from whatever track you choose.

Thanks, Porky. That’s exactly what I’m doing. The alternative way to play it is using the three dots at the top of the listing (when you’re looking at the listing of tracks). I’ve checked back on my Asset settings and 100 was the limit set for dynamic playlists, so ny QB was behaving as expected. I’ve now increased that to 400 and re-started Asset. I’ll check it again now.
Have you updated your Lite to v4.8 firmware? If so, have you checked this functionality since?

The re-start does seem to have done something. The app has loaded 305 tracks this time. Perhaps as Porky suggests either Asset or the app ‘times out’ when it’s pulling the tracks in from the NAS (QNAP in my case).
I’ll monitor it over the coming weeks, but happy to hear from someone with a more technical explanation.

I’ve not updated the firmware. I’m on 4.6 on the Lite and 2.0 for my Mu-so (Gen1).

Mine is doing the same, except only loading one track. Ive been talking about it in the firmware thread. If i use a different app like hifi cast or bubble upnp the jukebox selection loads fine, its only using the naim app that the issue arises. It would be helpful if you mentioned it the firmware thread or emailed naim as at the moment i feel like im the only one with the issue and they dont really understand what i mean.

1 Like

My observation is that it’s loading 95 songs less than Asset seems to create. When the Asset dynamic playlist length is 100 it loaded 5, when it’s 400 it loaded 305. I’ll perhaps change the value to something else to see if this holds true.

At this point id be happy with 95 songs less than the server creates. All im getting is one song on a playlist and its doing my head in. Naim support say a new firmware is due late November but at the moment this isnt useable for the way i want to. will end up having to sell it and get a cambridge audio evo or something that might actually work.

Mt theory is further confirmed: changed the Asset setting to 200 tracks per dynamic playlist, and the Naim App loads 200 - 95 = 105 songs into the play queue. I’ll add something into the other thread.

@skimminstones what software are you using to serve the tracks up to your Naim?

synology NAS > Asset server > Naim app

Okay, so when you go into the Options section of the Asset setup on the Synology, what value is set for the number of tracks in the dynamic playlists? And have you tried changing this?

Yes, tried every option in their. Its the naim app at fault. Asset server works fine with a jukebox selection if you use a different app. Its only the naim app that is having the issue. No matter what i try in terms of resetting, reinstalling etc changes this.

Naim support said its an issue with current firmware not reading tracks with special characters in but i dont believe thats the issue. My tracks dont have that and it wouldnt explain why only 1 track loads as a playlist.

1 Like

Just to say I have update my Lite to the latest firmware (4.8) and all seems fine.

It’s loading 500 tracks and playing OK.

1 Like

Thanks Porky. I think this is related to the new platform / firmware 3.7 as my Qb is behaving properly.

1 Like