PC crash during firmware upgrade

Having finally worked out how to get my usb/rs232 driver at the correct version, I tried to do a v4.7 update for my aging unitiqute today.

After 164 lines were transmitted, the Win 10 PC crashed and had to be restarted.

The Uniqute screen now says Firmware upgrade Do no switch off.

Any advice? Is it safe to switch it off, I assume no update has been done yet?


When I try to restart the updater, it is not able to identify the network address of the streamer, and states the product being update has no ARM application code loaded so it’s address cannot be resolved. (However I have not switched the device on and off as per the instructions)

The next screen states - Update will reload the application and then the update will attempt to resolve the network address.

It then goes to the version selection page, and after pressing next starts the update process, which again crashes the PC.

I believe that you should restart the firmware update from scratch and turn the streamer off and on again as normal.

But I wonder why it’s crashing the PC. Probably worth doing a restart of your PC too.



Thanks David,

I have been forced to restart the PC, blue screen of death, so your question is a good one, why is it crashing the PC.

I am concerned about just restarting the streamer, in case i bricks it altogether, but i would hope it does not delete the old version before uploading the new one.

Will probably call Naim in the morning


My PC ran slowly today and then said there was a W10 features update.


I don’t think it can brick it all together because there is a persistent boot programme in the streamer that will always respond to the updater. But ringing Naim is no doubt a good thing to do.

The updater really shouldn’t crash your PC though, whatever the streamer is or isn’t doing. I never heard of that happening before and 4.7 has been out for ages.



The PC crash might be caused by a problem with an auto Windows 10 update, there are some words about it on www search. It’s an update number something ending with 44, I can’t do much other than that at moment as away from home (Twickenham rugby) & am working off iPad. I uninstalled mine last week to avoid the potential of blue screen.
I suggest to either search for the www published solution, or simpler, to wait until after the next big Win 10 update that requires a system restart, that should contain the fix. I suspect it’ll be in the next week.

Correction: The MS Windows 10 update problem is with update KB4532693
See / search www for info & decide if you want to fix or wait

Thanks Mike and David,

I did downgrade Windows, but it made no difference.

Will try an older laptop later, but it looks like a trip to Salisbury will be required to fix it, it is stuck in firmware update mode.

I would try an e-mail to naimsupport first, they might have a simple unlock trick…
And with nothing to loose, & assuming its not actually ‘stuck’ & unable to move out of update mode, I would try to see if the player can be reset to factory default - item 4.11 in the manual
“Reset All Settings.
Warning displayed: Resetting to factory defaults.
You will lose ALL user settings.
Press front panel Logo to continue.”

One other thing you might try is a different updater program. For example you could try 4.3 . There is no problem in going backwards in firmware updates in the legacy streamers.



Thank you for the advice gentlemen.

I used another laptop , also win 10, and was able to install v4.4 successfully.

I am wondering it was something with the config on my work laptop.

So we are back in business.




I would guess that you could now do the 4.7 upgrade too.

Yes as ChrisSU says.

Also 4.4 lacks the Tidal and Spotify libraries so it’s not the best one to land on, which is why I suggested 4.3, but I would certainly try 4.7 again now.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.