Playlists in Asset don’t automatically move to the next track

I’ve finally got around to getting my Synology NAS, and have setup Asset.

I have a separate folder for Playlists, which have been exported and manipulated (via some shell script I wrote) from my iTunes Playlists.

The Playlists all appear OK, however when I click on any of the tracks via my NDX2, it does not then automatically move onto the next track when it gets to the end.

Below is an example of one of them

#EXTINF:166,Lullabye Of Broadway - The Andrew Sisters
…/MusicRAW/Various Artists/Peppermint Candy CD1/04-Lullabye Of Broadway-The Andrew Sisters.flac
#EXTINF:172,Night And Day - Artie Shaw & His Orchestra
…/MusicRAW/Various Artists/Peppermint Candy CD2/06-Night And Day-Artie Shaw and His Orchestra.flac
#EXTINF:244,Sing, Sing, Sing - Benny Goodman & His Orchestra
…/MusicRAW/Various Artists/Peppermint Candy CD2/01-Sing, Sing, Sing-Benny Goodman and His Orchestra.flac

Is this the usual behaviour, as it does however move onto the next track on:

  • Tidal Playlists on the NDX2
  • USB Playlists on the NDX2
  • VLC connected to Asset Playlists

Any help of guidance would be greatly appreciated - Thank you in advance

My playlists work fine from Asset (on a Linn streamer).

There was a change in Asset R7.4
Playlists should be in a folder as referenced by Asset and not in sub-folders which earlier versions accepted.

As you can see my playlists look like yours - EXCEPT slashes go the other way!
#EXTINF:256,On Every Street - 5 - The Bug
…\music\Dire Straits\On Every Street\05 Dire Straits - The Bug.flac
#EXTINF:355,Modern Times - 1 - Thunder on the Mountain
…\music\Bob Dylan\Modern Times\01 Bob Dylan - Thunder on the Mountain.flac
#EXTINF:253,Marc Cohn - 1 - Walking in Memphis
…\music\Marc Cohn\Marc Cohn\01-Walking in Memphis.flac
#EXTINF:297,The Way It Is - 5 - The Way It Is
…\music\Bruce Hornsby\The Way It Is\05 Bruce Hornsby and The Range - The Way It Is.flac

1 Like

Thanks for the response. I’m using Version: R7.5, so I guess it’s possible a bug has returned. There are no folders in my Playlists folder, and as you say, format is almost identical.

I thought my slashes should be Ok as I believe Synology is based on Linux, but I just tried it on one, and SUCCESS - so simple when you know how, and you have access to people that know

Many thanks indeed Paul, I’ll go off and amend my script to fix them all :slight_smile:

Glad it worked out OK.

Asset changed the sub-folders issue in R7.4 because a user asked them to!
I thought it strange as it then caused an issue for some other users and if you don’t want sub folders then you don’t have to use them.

They may change it back later (I think R7.5 however is basically the same as R7.4).

They probably changed it because there are more Windows users than Linux/Mac, and perhaps Playlist generators may mostly generate in Windows format.

Now I know, I’ll keep an eye on it for the future updates - Thanks again!

For clarification, it was only allowing a folder and not using sub-folders within it that changed.

P.S. You can of course reference several playlist folders in the Asset configuration if you need to.

1 Like

OK, well not quite there. After scripting the change, the issue is back. I think the problem relates to my script and the difference between linux and windows text files. One has a CR character at the end, the other has CR and LF (line feed), so I have a little more work to do on my script, but will try again to fix it tomorrow

1 Like

Well sorry for the delay, but I sort of got side tracked. I came across an issue that needed resolving first.

The problem was that where a filename or Artists name contained an 8 bit character (I.e. Michael Bulblé), the playlist would show a corruption and would not play. This was somewhat different to VLC player which would show the corruption, but would play OK.

Anyway to cut what was a very long story short, I fixed this as follows
Rename the Playlist from *.m3u to *.m3u8 AND restart Asset.
Screenshot 2023-02-12 at 23.26.08

It appears that the m3u playlist format is a bit of a loose format, and software developers therefore have the option to allow anomalies that are not part of the loose standard, or block them. So far it appears that VLC player is very forgiving, but Naim is less so. So no-one is doing anything wrong, but it means you get different results from different UPnP Players/servers.

Anyway with that out of the way, I still have the original playlist issue whereby under Naim app (not VLC, which works OK) it does not proceed to the next track. So need to do more investigation. I have one working, and the rest fail. Tried forward and back slashes, and removing quotes from playlists names, but no change. In a couple of cases if I edited a playlist, delete all but the first few lines, saved it, then put the lines back, and the playlist would work. Very strange, and inconsistent.

This is a working one with the play all button at the top

This is a failing one which will only play the track you select

Anyway, I feel this will be a long one, but enjoying the challenge at the moment

I have always experienced this behaviour ever since installing Asset to use with Naim (previous system was based on Logitech Media Server). If I scroll through the playlist tracks on the Naim app and select one, then only that track plays, as if the system is treating it as a separate album. If I browse to a playlist and select the top “Play” option then the whole playlist plays through from start to finish. I just though that this behaviour was by design.

The problem I have is the “Play” option at the top is missing on all but one playlist. When it doesn’t work (second graphic), it just shows all the tracks, then puts them in alphabetically order which is really strange. As no-one else has mentioned it, it might be something I’m missing, but as the working ones generated in the same way as all the others, it doesn’t make a lot of sense. I’m hoping when I get down to look again, there may be some Asset logs that may give a clue.

On my system, once I have selected a playlist and can see the list of all tracks in the playlist, I can click on the ellipsis (3 dots) in the top right hand corner and that gives me the “Play” option.

1 Like

Wow that’s brilliant - I really hadn’t noticed that. Yes that works just fine. Doesn’t explain why I dont get the play symbol at the top of all my Playlists, but certainly a good alternative. I suspect there is a bug somewhere, but less inclined to chase it now.

Many thanks for that!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.