Portable external hard drive not recognized anymore


A friend and I have a new problem with our portable external hard drives.
The NAS are working well, however when we want to play music via our portable external hard drives (via front USB port), they are not recognized anymore.
When placed on USB ports of our Mac, they are well recognized and the music heard is fine.
The portable drives were both formated via Mac, in FAT32 format.
The music is organized in folders using iTune (Apple lossless).
Our older portable drives work fine.
Has anybody having the same problem with new portable drives formated recently?
Thank you in advance for your help.

What is the equipment that is not recognising your hard drive ?

It would be helpful if you could fill out your profile detailing your gear. If you on my name, you will see an example.

Have you tried a flash USB drive with a bit of music on it as a test?m. Also with it plugged into the MAC, may be worth going to Utilities/Disk Utility and running the First Aid option to test the drive.

I had exactly this problem on my Nova. (See the thread “Nova setup issues”.) What fixed it for me was going into the app, other settings, and switching OFF server mode. I can’t explain why this worked - it seems counter intuitive to me. But it did work and my outboard ssd has been working fine ever since.

(I’m guessing you have a Uniti of some kind.)

The other thing you should try, and assuming it is Naim gear, it to power to off for 15 minutes - actually unplug from the wall, and don’t just shutdown. Particularly useful after a firmware update. It might sound useless, but has fixed so many issues reported on the forum previously.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.