Problem with multiroom feature with UPnP input since Naim app .23 release (maybe coincidentally)

I bought 3 Muso-QB 1st gen. in July 2020. All 3 are wired to the LAN so I just need the WLAN for the Naim app and I enjoyed especially the multiroom feature. I uploaded all my CD’s to the Synology media server with the AIFF format with a bitrate of 1411 Kbit/s and a audio sample rate of 44.100 kHz. When I open the Naim app and choose the UPnP icon, it shows my DiskStation and I can choose music by Folder or album etc. I choose what I want to play, then select the Naim App Now Playing screen and touch the multiroom icon to let the music play synchronically in 3 rooms. It worked perfect. But I’m feeling a bit desperate because since I got the .23 release of the Naim app on my Android (ca. 10 days ago, but this might be a coincidence and the problem has nothing to do with the .23 release) there is no more a multiroom icon when I select the Now Playing screen. The UPnP brings the same screen as in Analog input. Nothing about a multiroom icon. Just the volume slider, that’s all. And yes, the multiroom function is activated and still works fine with radio or USB or Spotify. And I had no changes in my network at all. I read a lot in this forum and I rebooted all components of my network. It doesn’t work anymore like before. Any help would be appreciated.

Basically I think you’re saying that your multiroom icon has disappeared?
I just checked on upnp on my Muso QB2 and QB1 and all work as they should (apart from not being able to independently control their volumes, only as a group)

I reinstalled the Naim app already several times and also deleted all data doing so. Something must be wrong with the Naim app. Now I just found out how I still can get the music played on multiple QBs. I first choose a radio station and let it play in multiroom mode on multiple QB’s because here I get the normal multiroom screen. Then I change to UPnP and choose some music and it will be played on multiple QB’s although there is no multiroom screen, just the Analog input screen. Still it’s not what I expect because I don’t have the random access or replay icons.

I should add I’m using my iPhone 11 for the app. It seems there may be an issue with the Android version as mine on iOS is working OK.

Hi @Bmettler

Can you get a support ticket raised to our support desk with as much info as possible regarding:

  • Versions of UPnP server used.
  • Phone & Android version its running
  • Code version running in the Qb’s (I assume v4.8)

I spent 5 mins trying it here but couldn’t replicate the issue, so there must be some other factors in the mix that breaks it. If possible see if using a different UPnP server works (eg. use Asset running on a PC as a test).

For reference here is mine playing an AIFF test track (it has no artwork in this test track).

Best regards

Steve Harris
Software Director
Naim Audio Ltd.

Hi @Stevesky

There is already a ticket number: 129331. But I don’t know how to add information in there. I sent the following information to but then a new ticket number was raised.

Here some info you asked:

My phone is a Xiaomi Red 7A with Android version 10 QKQ1.191014.001

My UPnP server is the MediaServer package from Synology on a DS1511+ with DSM 6.2.4-25556 Update 2. The mediaserver is responding well and playing the music on a single Mu-So QB but just shows me the Analog screen instead of the multiroom screen. If I choose first Radio and multiroom to let it play on multiple QB’ and then change to UPnP to choose some music, it will be played on multiple QB’s.

I understand that I have to use the Naim app to get the firmware version of the Mu-So QB’s like written in the product manual. If I run the firmware update routine it searches for 1 minute and then leaves the update screen and just goes back to settings. I get no information.

Hi @Bmettler

Thanks for the extra info. After some more experimentation the issue has been replicated here.

I’ve raised it as a Jira to the apps team and will discuss with them next week when the office opens. We’ll aim to get this fixed in the next Android app service release.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.