Problems connecting Mu-So 1st gen

Hi!

Lately I’ve had some problems with my Naim Mu-So 1st gen.

Suddenly one day I was not able to connect via Naim App and it suddenly dissapered from my list of Naim Mu-So’s.

When reseting it and then trying to reconnect when the flashing purple app shows, I manage to get it to show in the Naim app but when pressing on the icon nothing happens. It is toally unresponsive. I have tried this from different devices, reinstalling the naim app, but problems still persist.

Anyone know how to fix this?

Have you tried clicking on the little > symbol to the right of the Qb icon? (Clutching at straws, I know.)
Have you tried moving the Qb nearer to the router to complete the set-up? They’re not the best of things in working with wifi in my experience. I had to do this when I got my Qb a few years ago (and I use it hard-wired to an Apple Airport Express to improve its connectivity).

Reboot the Mu-so?

Hi Mike, Are you running iOS 14.2? It contains an Airplay bug.
This manual workaround may help: https://naim.freshdesk.com/support/solutions/articles/33000258053-how-to-complete-wi-fi-setup-of-naim-product-with-ios-14

1 Like

Thanks! The 14.2 workaround did the magic, but still have some issues.

First I managed to get it connected and set up radio channels via the app. Then it disappered from the app, but still connected to Internet since I can play radio and change channels.

Tried to reset Wi-Fi now and it shows up in the app, but now won’t connect to the internet.

Seriously buggy…