QB & Mu-so.2nd Generation won’t play together

Had QB for a year. Bought Mu-so. 2nd Generation today. Ethernet connection for Mu-so. QB wireless.

Fibre 150mb connection.

Will not play simultaneously.

Have I missed some set up features.

Please advise

Have you tried touching the multiroom button in the app?

Yes. Doesn’t work through the app or remote control.

Is the App ‘seeing’ the other device when you press the multi room icon as HH suggests…? If the other device is not listed, it may start to point toward a network issue….


Are you getting a screen like this when you touch the four little squares?

App does see the other device, just won’t play.

Have you tried starting from the other player? If the Qb is first generation, you can’t stream high res from it to other players, which may be the issue, though I’m not sure if it applies to iRadio.

QB is second generation.

But starting from the QB - multi-room now works. QB is wireless, Mu-so ethernet - weird.

Thanks for your help

I suspect it’s a network thing. The WiFi box can find the wired but not vice versa. If you try wiring the Qb I suspect it will work both ways.

The multi-room worked for a while but then kept dropping out.

In case anybody else runs into the same issue.

I had to force the QB Wi-Fi to use 2.4GHz. My router is an eero6. Went to settings>>troubleshooting>>my device won’t connect>>my device is 2.4 GHz only>>temporarily pause 5 GHz.

Appears to be stable now.

1 Like

Unfortunately, now keeps changing back to the 5Ghz connection and all streaming continues to be interrupted when using multiroom.

Does your router allow you to use different names for the 2.4 and 5gHz bands?
I had to rename / split the bands with my old router, so that my Muso-QB always stayed on 2.4gHz.
However, my new router seems to have better implementation of band steering and it has been fine so far; 1 week.
EDIT: Famous last words. This morning, my app was not connecting to my equipment, dropping out, disappearing NDX2, and QB’s.
I have now turned off the 5gHz band and normal service has resumed. I need to investigate further…

I had to contact ISP to force it onto the 2.4Ghz connection but mine now working OK.

I have sufficient knowledge to turn off band steering which separated the 2.4 and 5 bands.
The 5gHz band SSID now has a “5G” suffix, so my QB’s only connect to the 2.4 band.
I can easily choose the 5gHz band for my laptop for speed, but all of my kit plays nicely now.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.