Qobuz Issues: Downloading

I am new to streaming but recently took up the Qobuz free trial. The streaming side seems to work fine and consistently.

My issue is with purchasing and downloading albums. This seemed to work fine the first couple of times but yesterday and today, after adding to my download queue in the downloaded app, the “start download” button does nothing and the queue just sits there. I have tried restart my Mac and reopening the downloaded but no luck.

I am wondering if this a problem on the Qobuz end, perhaps their servers are down or overloaded. Have others experienced this from time to time or is there a solution at my end? Thanks so much.

I think you have to have a paid subscription before you can purchase downloads.

You don’t need a subscription to purchase tracks, so must be another issue.

I find the app doesn’t open automatically. However if you make the purchase, open the app and login then look in purchases it is there ready to download . You can also go into settings and set the download destination.


Thanks Bruce, what you describe is the other issue I had getting my purchases to show up in the downloader but I figured out the same workaround for that. Now I have them in my queue on the downloader but the start download does not work. Looking at this further I see that a folder for the downloads has been created in the music folder on my NAS but that folder has nothing in it.

There has just been an update on the windows version of the downloader, I’d check you have the latest version for the Mac.

I just thought I would add that I have had no success in resolving this issue (refuses to complete download). My best guess is that the qobuz downloader does not work with the latest Mac OS (Sonoma). Interestingly the downloader does create an empty “original” folder but never gets to creating the “1” folder. I read somewhere that the contents of the “original” folder are transcoded into the “1” folder during the download process but this is not happening in my case.

There is another thread on Qobuz & downloading issues: “Qobuz - suddenly new” which might be of use/interest. I still continue to find issues with general Qobuz downloading being very fractious and like you, can wait for an age with items still in the download queue.

Thanks Paul. I did look at that thread which unfortunately does not describe my issue. Steaming works fine, downloading is a problem.

Just a small update, more public service announcement for any other people encountering similar issues.

The qobuz downloader app appears not to work with Sonoma.

My workaround was to use the Qobuz app and download music (that I purchased from the website) from the “purchases” tab.

Same process for me in Windows.


I used the Qobuz downloader last week with Sonoma on Mac m1 Studio without problems.


Thanks Ian. I got it to work initially to download a couple of albums through the downloader. Then it stopped altogether for a week, then downloaded one album in my queue. Has not worked that way since. I am using a somewhat older iMac, perhaps that makes a difference. I did update my version of Sonoma to the latest version that was released a couple of weeks ago. That may also be the problem.

When I last used Qobuz downloader I was prompted to update it to version 1.0.32 and this what I used. Downloaded 3 HiRes albums (total about 3.5Gb) and it took a few minutes.

Cheers, Ian

Thanks Ian. I am using the same version of the downloader so I don’t think that is the issue for me. Very frustrating but perhaps will be solved by a future update to the downloader or Sonoma on my imac. Fortunately my workaround continues to work by downloading through the Qobuz app although I cannot get it to target the right folder on my NAS. It seems to always put the files inside a Qobuz folder it creates instead of my music folder. It’s a simple matter to copy the files to the right place so that is a minor inconvenience.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.