Question about Gigabit Ethernet LAN

This post is loosely related to streaming, but I’m really looking for some advice about Gigabit Ethernet.

I have a pretty basic home network utilising 2 Cisco switches as outlined in the following diagram and 2 Synology NAS devices one of which (SD216+II) hosts my music rips and the other (DS216) my media files (digital photos and home videos):

I have a broadband connection from Sky (with a 2 Tb SkyQ router) providing an internet bandwidth of around 72 Mbps and have absolutely no problems streaming music to my hifi systems over ethernet (or wifi) nor streaming photos or videos to my smart TV over ethernet.

Sometime last week, volume 1 on my media server crashed with a couple of bad sectors. Luckily the disk is backed up regularly to a hard disk (stored elsewhere), so I was confident about getting the device up and running again. I was able to read the disk using the Synology Assistant application and so backed up the files to another USB drive before repairing the 2 Tb WD Red disk in the NAS. I took the opportunity of upgrading to a 4 Tb WD Red Plus drive before initialising the drive and restoring my media files. I am now back up and running successfully, but the exercise brought up some issues with respect to my home LAN.

I discovered that when backing up and restoring my files I was only getting a file transfer rate of just under 10 MB/s (or 80 Mbps). That is ‘Fast’ ethernet rather than ‘Gigabit’ ethernet. It would have taken ages to complete the file backups and restoration with this transfer rate, and so I resorted to disconnecting my Media NAS and transferring the files over USB 3.0 which gave me a file transfer rate of around 75 to 105 MB/s (or up to 840 Mbps).

I’m now trying to figure out why I am not getting gigabit ethernet rates over my LAN. The ethernet adapter in my PC supports gigabit ethernet. Both of my NASs support gigabit ethernet as do (I think) my two Cisco 2960 switches (set to factory defaults) and all of my ethernet cabling which is mostly BJC Cat 6a, with one or two generic cat 5e cables. I have tried testing transfers to both NAS devices and have tried swapping ethernet cables to my NAS devices with no effect. The ethernet ports on my Cisco switches all flash ‘green’ which I believe (although I may be wrong) suggests that they are operating at gigabit level.

Why do I not get gigabit transfer rates over my home network? Any suggestions would be greatly appreciated.


It has just occurred to me having written this post that I have assumed that the 2Tb Sky Q box incorporates local gigabit ports. Can anyone confirm that this is the case?

Are you sure the Cisco switches run GB ports rather than just 10/100? Many of them have ‘fast’ ports, apart from the one or two uplink ports on the R side which are GB.

1 Like

No I’m not!

Although I thought I’d read that if they flashed green rather than orange then they were Gb ports. Maybe I’ve got that wrong! Maybe orange represents 10 and green represents 100. I guess these switches are so old that the standard 8 ports may not support Gigabit. That would certainly explain the transfer rates I was getting!

I’m sure all of the ports on current Cisco switches would support Gigabit!

Can you try connecting them using only the uplink ports? That should ensure that they can run at GB speeds so at least you will know if this is where your bottleneck lies.

1 Like

Thanks Chris.

Yes - I will do that after I have completed the transfer (over USB 3.0) of my remaining large video files.


I’m pretty sure my Cisco 2960’s only run 10/100, (or whatever the slower speed is!) through the usual 8 ports. I think it has one, separate hi-speed (1000?) port to the right of all the other ports. You could try using that other port on the right and see if the speeds improve?

Although my understanding is that the hispeed ports are noisier, and audio streaming doesn’t need hispeed, so for streaming, you may be better off keeping away from that??

Good luck.

1 Like

Other thing to check is the NAS config if is not affecting performance.
I have an older NAS Synology DS 713 purchased in 2015. Added an expansion unit and after several power breaks in my area, crashed badly but I defined RAID so I rescued everything with no issue only changing one Red HD, when has a bad sector is very difficult to recover. Better to service it. Since the crash I added a nice UPS and no issues last 3 years.

Regarding the switches I have 3, only one is Cisco ( main one) after the router to distribute internet, have other 2 cheap switches bought in Amazon for $20. these switches every time to time cause issues, I change them every 2 years.Almost all cheap switch technology now is fast speed I will ensure your switches are working well, these things are simple tech and does not deserve to spend money on it.

Last, having 2 NAS could be an issue too. With the expansion unit my NAS has 17 Tb more than needed of course RAID uses much more bytes to mirroring data but I believe for home systems is better to reduce number of connections if possible.

1 Like

You must be choosing some really bad switches if they need replacing every two years. I have never known a switch to fail, and the Catalyst switches many use are often decades old.

When you say ‘fast’ speed, presumably you mean Gigabit? Fast is generally used to describe 100MB ports.

Yes Gigabit.
Last switch I bought costed $15. TP Link TL-SG105. Yes these fails every time to time, get without power and fails, that’s the reason I don’t invest on something more expensive. I know they last years when you have a technician doing maintenance, not my case unless my son wants to dedicate time to my network when he visits me. He is the specialist !
I saw the Catalyst are discontinued and unsupported.

The older blue Cisco 2960 tend to have a 1gb uplink but the 8 ports are 100mb for connected to devices. The white later models where all gigabit.

1 Like

Your Sky Q hub should be gigabit, your Cisco 2960s will be fast Ethernet (100Mbit) unless there is a G in their designation, eg 2960-GC (there are many combinations - you’re looking for a G - ignore other letters).

Also note that Windows Explorer doesn’t always run as fast as you might expect, especially when the drives are off-board as the copy goes disk->pc->disk and not disk->disk as you may expect.

DNS issues can also slow down a copy if the initial lookup takes an age, but it doesn’t sound like this is your problem.

1 Like

It makes zero difference in my experiences the obsession with noise that may or may not exist really becomes to obsessional. I have full gigabit these days it made zero differnce to the 100mb Cisco’s I did have before.

Ah, ok fair enough. Not something I’ve tried if I’m honest; just seem to remember reading about that somewhere, hence why I only suggested it may make a difference. Don’t remember the actual circumstances in which that suggestion was made, but I guess the findings may have been more to do with the actual quality of the switch rather than the speed??

Interesting! Do you think that is definitely the case? I have one older blue Cisco 2960 switch and one of the later white models. It was the white switch to which I was referring when I mentioned the flashing green LEDs on all of its ports. I did try testing transfers via each of the switches in turn, but got the same results from both - approx 9MB/s; in other words ‘fast’ ethernet and not gigabit.

I think it is likely that the ports on my switches are running at 10/100 rather than 1000, and could potentially resolve this by buying a couple of new consumer switches to replace the Ciscos. However, the truth of the matter is that no matter that it would be nice to have a full gigabit home network, I really don’t need to have one. It’s only on the rare occasion such as the demise of my WD drive that I need the extra bandwidth, and even then I can get around the relatively slow ‘fast’ ethernet connections by using USB 3.0 for all (or at least most) of the large file transfers.

I just run a Netgear GS108 for all the devices that need Gigabit connectivity and then connect the Cisco 2960 to the Netgear. Keeps Roon nice and responsive and copying from NAS to Roon Core nice and speedy compared to connecting via the 100Mb ports on the Cisco alone.

1 Like

Not all of them are no, check your model number to find out will be the easiest way.

Some of the 2960 switches have 10/100/1000 ports and some don’t - see CISCO data sheet at:

Thanks! I had actually found that document. However, I found it difficult to identify my specific model. My switch (the later white version anyway) is simply labelled as 2960 C series as far as I can see.

However, I think it’s pretty obvious that the 8 standard ports on the switch are just 10/100 (fast ethernet) and not 1000 as I had originally assumed.

I’ll consider whether or not it’s worthwhile getting a cheapish gigabit consumer switch for my network, but I may not bother.

The only application I use that may just benefit from a gigabit connection is Roon, but I can’t imagine that it needs a connection that fast.

Lots of the later white Catalysts were 100MB too, you need to check which model you have.

You really don’t need a GB network to stream music, 100MB is fine. GB will help to speed up file transfers but for music use that’s not going to be a regular thing.
I’m not entirely convinced that this is the cause of your slow file transfer in this case, but you could eliminate it by trial and error easily enough.

1 Like